summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-30 10:14:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-30 11:14:28 +0100
commitba0b81af6736e1be8209ffa4e24a658642c15662 (patch)
treeac0403b433ed6818a4a7c5040496cdea1c042f61
parentsys-apps/iproute2: Removed old. (diff)
downloadgentoo-ba0b81af6736e1be8209ffa4e24a658642c15662.tar.gz
gentoo-ba0b81af6736e1be8209ffa4e24a658642c15662.tar.bz2
gentoo-ba0b81af6736e1be8209ffa4e24a658642c15662.zip
app-editors/nano: Bump to version 2.9.3
Package-Manager: Portage-2.3.21, Repoman-2.3.6
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-2.9.3.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 559e402ff262..bd18410966a5 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -2,3 +2,4 @@ DIST nano-2.7.5.tar.gz 2031723 BLAKE2B 30cd6418c438d6a908d7bf0f64151f6fa3c9aa41f
DIST nano-2.8.7.tar.gz 2822417 BLAKE2B 2559497b9aee4d4c3cfc86e8af6a54bc0af58588c7bd1142a0e97c6ce50aed66c3852745b83a457263659e97592f0775dcc94c44d818e20440b6524202bfe49a SHA512 511b57f8fe82872827829bca91f7a8666a6ee75924cf2c853332ddd0467abf281c6d3cbaa5dd208c579cbace5bef23d36bd7b62be116aa2175262ed1d15aaf79
DIST nano-2.9.1.tar.gz 2839465 BLAKE2B e0d443dc3c86446478edad73042c6b4698a86fdfe3727deac858fa99d52bf319e2b3a120ba57bf79f3b78d9d3d7e8f4b5bdee234f6450882fee06647be371191 SHA512 7eeefd4cb5f02f1ac14ca10c536f873a1a85f3a5ccc5d5c40a12770b26dd0d5b0bbb3a0770b394779c8234891d7226e0d06d72465d7687c971bc62606100d0b6
DIST nano-2.9.2.tar.gz 2839256 BLAKE2B 6e27ad0ff72a17461d614f2222ef33bf2abaaa0f4576a8e378524b090c702adafa86e78d976cf5b5dcd2ca1da802aeeff9b3f4bc5e81fa31b8164ef2979708d6 SHA512 b45afb593a04029a137f49551242f2dae901482878cca4aac6cba1c0c8af38a83994daadbd025e90f019cfa9d1273784de4491bbadf47104914904af804661d1
+DIST nano-2.9.3.tar.gz 2874342 BLAKE2B f0983af89037c15747e416df8b156d325994244dce3a1d3339a0a34597d6b25a1888132d28b393cde36c7fd18375036816a9e7f6b26afe8a85ea32b27dee4969 SHA512 cce389a00dc4db899d7f73522e991bee5fa1fd0538a1af08aa75563e29e6cfba38b53acbba1d95e7876f3cac6298b5cada102d700334446419aadfe61ac18d2a
diff --git a/app-editors/nano/nano-2.9.3.ebuild b/app-editors/nano/nano-2.9.3.ebuild
new file mode 100644
index 000000000000..74791e406856
--- /dev/null
+++ b/app-editors/nano/nano-2.9.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ inherit git-r3 autotools
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+ !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir=/trash
+ $(use_enable !minimal color)
+ $(use_enable !minimal multibuffer)
+ $(use_enable !minimal nanorc)
+ --disable-wrapping-as-root
+ $(use_enable magic libmagic)
+ $(use_enable spell speller)
+ $(use_enable justify)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable unicode utf8)
+ $(use_enable minimal tiny)
+ $(usex ncurses --without-slang $(use_with slang))
+ )
+ case ${CHOST} in
+ *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+ esac
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/trash
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED%/}"/etc/nanorc || die
+ fi
+
+ dodir /usr/bin
+ dosym ../../bin/nano /usr/bin/nano
+}