summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-11-14 16:48:03 +0100
committerSam James <sam@gentoo.org>2023-11-17 11:07:57 +0000
commitba1af88fd6f662102ff33d552461b8045ec0a9bf (patch)
tree9cae3e3a2c21b4641e6d3b5136fd6991d428ab89
parentnet-im/synapse: add 1.96.0 (diff)
downloadgentoo-ba1af88fd6f662102ff33d552461b8045ec0a9bf.tar.gz
gentoo-ba1af88fd6f662102ff33d552461b8045ec0a9bf.tar.bz2
gentoo-ba1af88fd6f662102ff33d552461b8045ec0a9bf.zip
mail-filter/rspamd: add 3.7.4
Unneeded dependencies detected by qa-vdb: - sys-apps/file - Upstream does not use it since version 2.0, see [1]. - dev-libs/libev - Upstream bundles this library since version 2.0, see [2]. It contains few incompatible changes [3-5], which make unbundling currently unfeasible. dev-libs/libfmt and dev-libs/xxhash are DEPEND only, detected by qa-vdb. Upstream uses them both in inline mode, see [6] and [7], respecitvely. Upstream bundles backward-cpp [8] since version 3.7.1. It was necessary to disable its auto-detection property. The last release was in 2021, so I decided to keep it bundled for now. This version also contains the fix for GCC 14, see bug 916438. [1] https://github.com/rspamd/rspamd/commit/56e236efa012c4be6b3893314ce4d3a570e16327 [2] https://github.com/rspamd/rspamd/commit/5376c8a25208ae4c7c21c2ff1894a5ebb2df6340 [3] https://github.com/rspamd/rspamd/commit/7c4eb706c124806d254af6033c7023ee488b2c6c [4] https://github.com/rspamd/rspamd/commit/b3713de7cefa87af9ed95d091db497cef63502d0 [5] https://github.com/rspamd/rspamd/commit/0194245dcdbecfb34088339689668fd6c1111cb8 [6] https://github.com/rspamd/rspamd/blob/3.7.3/CMakeLists.txt#L264 [7] https://github.com/rspamd/rspamd/blob/3.7.3/src/libcryptobox/cryptobox.c#L30-L31 [8] https://github.com/bombela/backward-cpp Closes: https://bugs.gentoo.org/916438 Closes: https://bugs.gentoo.org/916488 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mail-filter/rspamd/Manifest1
-rw-r--r--mail-filter/rspamd/rspamd-3.7.4.ebuild152
2 files changed, 153 insertions, 0 deletions
diff --git a/mail-filter/rspamd/Manifest b/mail-filter/rspamd/Manifest
index 1b41c11b39d2..92cf611c46f0 100644
--- a/mail-filter/rspamd/Manifest
+++ b/mail-filter/rspamd/Manifest
@@ -1,2 +1,3 @@
DIST rspamd-3.5.tar.gz 5806722 BLAKE2B 547cd9bb26942dc584d1f4b164e61bdb15505a56399fa19b358b7d7525ee983acc8d5ae1fdb3de340e3461a03aedbb48266fd81404c1f4a2e8fc5bd6735d9a62 SHA512 39c87d5dfd9ae1fc7709e19967eac5e7c7dc83fa070dfebbb7ab5411d7d50d6e6f10248ada717cf1cb3f6ff6c5bfb4d31fd87e1a7e1b2e5f876f6be7b5705623
DIST rspamd-3.6.tar.gz 5843907 BLAKE2B 2ccb3e65a14624d48540bd3e2d034fec0dd89cd75032ade3ca74ded09cee6ed67f670c31035b18583b850cc4efeb21b44f97ec2c35d518a49b0c4e6f0eb8c90f SHA512 d99e2a60eec94eb39902454a8041eeb76f673c9f784849128766323a218d6c419755e0f8819e2a6921ca08c6a7d63660dc87bc911f808fb4a67d29e8fbfc571b
+DIST rspamd-3.7.4.tar.gz 5903754 BLAKE2B d13b3451b4a6a7c5e8644ba57196190065edda2fc48e7245ef7e0094cb90838760cc124a2cf8d0b4b7519c7583284f6883fbcd4bf3a6489496b5e52234a36c21 SHA512 a82696957417f7197b59e614012176626b4fdf1464ed38ce57552c8a02fe2e426504e0b0780ab4f36d208a11ae4d1921bacee52341c8a906b4ab19c1719fd116
diff --git a/mail-filter/rspamd/rspamd-3.7.4.ebuild b/mail-filter/rspamd/rspamd-3.7.4.ebuild
new file mode 100644
index 000000000000..7f70037f8cbe
--- /dev/null
+++ b/mail-filter/rspamd/rspamd-3.7.4.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit cmake lua-single pax-utils systemd tmpfiles
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/rspamd/rspamd.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rspamd/rspamd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Rapid spam filtering system"
+HOMEPAGE="
+ https://rspamd.com
+ https://github.com/rspamd/rspamd
+"
+
+LICENSE="Apache-2.0 Boost-1.0 BSD BSD-1 BSD-2 CC0-1.0 LGPL-3 MIT public-domain unicode ZLIB"
+SLOT="0"
+IUSE="blas cpu_flags_x86_ssse3 jemalloc +jit selinux test"
+RESTRICT="!test? ( test )"
+
+# A part of tests use ffi luajit extension
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ test? ( lua_single_target_luajit )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ dev-lua/LuaBitOp[${LUA_USEDEP}]
+ dev-lua/lua-argparse[${LUA_USEDEP}]
+ ')
+ acct-group/rspamd
+ acct-user/rspamd
+ app-arch/zstd:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/icu:=
+ dev-libs/libpcre2:=[jit=]
+ dev-libs/libsodium:=
+ dev-libs/openssl:0=[-bindist(-)]
+ dev-libs/snowball-stemmer:=
+ sys-libs/zlib
+ blas? (
+ virtual/blas
+ virtual/lapack
+ )
+ cpu_flags_x86_ssse3? ( dev-libs/hyperscan )
+ jemalloc? ( dev-libs/jemalloc:= )
+ selinux? ( sec-policy/selinux-spamassassin )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/doctest
+ dev-libs/libfmt:=
+ >=dev-libs/xxhash-0.8.0
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/ragel
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/rspamd-3.6-cmake-lua-version.patch"
+ "${FILESDIR}/rspamd-3.6-unbundle-lua.patch"
+ "${FILESDIR}/rspamd-3.6-unbundle-snowball.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ rm -vrf contrib/{doctest,fmt,lua-{argparse,bit},snowball,xxhash,zstd} || die
+
+ > cmake/Toolset.cmake || die #827550
+
+ sed -i -e 's/User=_rspamd/User=rspamd/g' \
+ rspamd.service \
+ || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFDIR=/etc/rspamd
+ -DRUNDIR=/var/run/rspamd
+ -DDBDIR=/var/lib/rspamd
+ -DLOGDIR=/var/log/rspamd
+ -DLIBDIR="/usr/$(get_libdir)/rspamd"
+
+ -DSYSTEM_DOCTEST=ON
+ -DSYSTEM_FMT=ON
+ -DSYSTEM_XXHASH=ON
+ -DSYSTEM_ZSTD=ON
+
+ # For bundled https://github.com/bombela/backward-cpp
+ -DSTACK_DETAILS_AUTO_DETECT=OFF
+
+ -DENABLE_BLAS=$(usex blas ON OFF)
+ -DENABLE_HYPERSCAN=$(usex cpu_flags_x86_ssse3 ON OFF)
+ -DENABLE_JEMALLOC=$(usex jemalloc ON OFF)
+ -DENABLE_LUAJIT=$(usex lua_single_target_luajit ON OFF)
+ -DENABLE_PCRE2=ON
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build run-test
+}
+
+src_install() {
+ cmake_src_install
+
+ newconfd "${FILESDIR}"/rspamd.conf rspamd
+ newinitd "${FILESDIR}/rspamd-r7.init" rspamd
+ systemd_newunit rspamd.service rspamd.service
+
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+
+ # Remove mprotect for JIT support
+ if use lua_single_target_luajit; then
+ pax-mark m "${ED}"/usr/bin/rspamd-* "${ED}"/usr/bin/rspamadm-*
+ fi
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rspamd-r1.logrotate rspamd
+
+ diropts -o rspamd -g rspamd
+ keepdir /var/{lib,log}/rspamd
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test "${ver}" -eq "3.4"; then
+ elog "rspamd-3.4 is known to segfault when it is updated from older version due"
+ elog "to a page-alignment of hyperscan .unser files. The issue was patched in"
+ elog "rspamd-3.4-r1 ebuild revision. All possibly broken .unser files will be"
+ elog "automaticaly removed. See https://github.com/rspamd/rspamd/issues/4329 for"
+ elog "more information."
+
+ find "${EROOT}/var/lib/rspamd" -type f -name '*.unser' -delete
+ fi
+ done
+}