summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-19 20:58:29 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-19 20:58:29 +0200
commitba1d226e066c03d6d4db683b699c4763979a42b5 (patch)
treef08a0d2d95b7227c292804ec53c99776237d55db
parentmedia-fonts/dina: Drop old (diff)
downloadgentoo-ba1d226e066c03d6d4db683b699c4763979a42b5.tar.gz
gentoo-ba1d226e066c03d6d4db683b699c4763979a42b5.tar.bz2
gentoo-ba1d226e066c03d6d4db683b699c4763979a42b5.zip
media-fonts/pcf2bdf: Bump to EAPI 7
Bug: https://bugs.gentoo.org/697308 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-fonts/pcf2bdf/pcf2bdf-1.04-r1.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/media-fonts/pcf2bdf/pcf2bdf-1.04-r1.ebuild b/media-fonts/pcf2bdf/pcf2bdf-1.04-r1.ebuild
index ecaa05f44c6d..c27ad5f8f8e8 100644
--- a/media-fonts/pcf2bdf/pcf2bdf-1.04-r1.ebuild
+++ b/media-fonts/pcf2bdf/pcf2bdf-1.04-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="Converts PCF fonts to BDF fonts"
HOMEPAGE="http://www.tsg.ne.jp/GANA/S/pcf2bdf/"
@@ -16,20 +16,18 @@ IUSE=""
S=${WORKDIR}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-64bit.patch
- epatch "${FILESDIR}"/${P}-gzip.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-64bit.patch
+ "${FILESDIR}"/${P}-gzip.patch
+)
src_compile() {
- emake -f Makefile.gcc CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" || die "emake failed"
+ emake -f Makefile.gcc CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}"
}
src_install() {
emake -f Makefile.gcc \
- PREFIX="${D}/usr" \
- MANPATH="${D}/usr/share/man/man1" \
- install || die
+ PREFIX="${ED}/usr" \
+ MANPATH="${ED}/usr/share/man/man1" \
+ install
}