summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-30 14:16:32 +1000
committerSam James <sam@gentoo.org>2022-07-30 06:21:27 +0100
commitba32223d42c808e20ec31c4ba54fcd9d7630e834 (patch)
tree76b2d4ddd6a177333bf5001eb03af96c881fe530
parentdev-haskell/filepath-bytestring: drop 1.4.2.1.6 (diff)
downloadgentoo-ba32223d.tar.gz
gentoo-ba32223d.tar.bz2
gentoo-ba32223d.zip
dev-haskell/persistent-sqlite: add 2.13.1.0
Closes: https://bugs.gentoo.org/861194 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/persistent-sqlite/Manifest1
-rw-r--r--dev-haskell/persistent-sqlite/persistent-sqlite-2.13.1.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-haskell/persistent-sqlite/Manifest b/dev-haskell/persistent-sqlite/Manifest
index d9ec9aa7dc0f..687af09a64ad 100644
--- a/dev-haskell/persistent-sqlite/Manifest
+++ b/dev-haskell/persistent-sqlite/Manifest
@@ -1 +1,2 @@
DIST persistent-sqlite-2.10.6.2.tar.gz 2220390 BLAKE2B f146ec84ae45d0d4b4cb3c809bf694182c8592369e222029824f6eb6a39abbbb67acc6bdd2af4a9b8080d50ffcdc20968fa14cac237a475b220dcefe3329fc2d SHA512 b1db41bf77ae53b99c28f3224c9a2b7335faa4a78c96487270249959cc9491fa542e28d38dd63a2b417580f6a41608ffcee152e8609fe16392005c728862c7bc
+DIST persistent-sqlite-2.13.1.0.tar.gz 2276809 BLAKE2B acc9f4b0e351313486e89f695b69756ea165146fd8aaafcc2d3da8dc620c109cee8d922fe0246e688691748c18e75fa64f9f4a992ca2cd28e01677766d56326b SHA512 19842dcd867f57ac2f81d8651838f41f6a4f0074293c0b3a21a52d2fb96410c26d5340307983da21ca89170a01621da257320e36f33170657acb6890f70299d4
diff --git a/dev-haskell/persistent-sqlite/persistent-sqlite-2.13.1.0.ebuild b/dev-haskell/persistent-sqlite/persistent-sqlite-2.13.1.0.ebuild
new file mode 100644
index 000000000000..fafaf61e1708
--- /dev/null
+++ b/dev-haskell/persistent-sqlite/persistent-sqlite-2.13.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.2.9999
+#hackport: flags: +systemlib,-use-stat3,-use-stat4,-uri-filenames,-full-text-search,-have-usleep,-json1,-use-pkgconfig
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Backend for the persistent library using sqlite3"
+HOMEPAGE="https://www.yesodweb.com/book/persistent"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="build-sanity-exe"
+
+RDEPEND=">=dev-db/sqlite-3.0
+ >=dev-haskell/aeson-1.0:=[profile?]
+ >=dev-haskell/conduit-1.2.12:=[profile?]
+ >=dev-haskell/microlens-th-0.4.1.1:=[profile?]
+ >=dev-haskell/monad-logger-0.3.25:=[profile?]
+ >=dev-haskell/persistent-2.13.3:=[profile?] <dev-haskell/persistent-3:=[profile?]
+ dev-haskell/resource-pool:=[profile?]
+ >=dev-haskell/resourcet-1.1.9:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ virtual/libc
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/exceptions
+ dev-haskell/fast-logger
+ >=dev-haskell/hspec-2.4
+ dev-haskell/hunit
+ dev-haskell/microlens
+ dev-haskell/persistent-test
+ dev-haskell/quickcheck
+ dev-haskell/system-fileio
+ dev-haskell/system-filepath
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag build-sanity-exe build-sanity-exe) \
+ --flag=-full-text-search \
+ --flag=-have-usleep \
+ --flag=-json1 \
+ --flag=systemlib \
+ --flag=-uri-filenames \
+ --flag=-use-pkgconfig \
+ --flag=-use-stat3 \
+ --flag=-use-stat4
+}