summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-18 15:59:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-18 16:47:30 +0100
commitba41b3eb046d61ed39edad9063cd83730f8ffaf0 (patch)
tree8b3be05170a316993f6f6de8dc724567646fb746
parentdev-python/psycopg: Remove old (diff)
downloadgentoo-ba41b3eb046d61ed39edad9063cd83730f8ffaf0.tar.gz
gentoo-ba41b3eb046d61ed39edad9063cd83730f8ffaf0.tar.bz2
gentoo-ba41b3eb046d61ed39edad9063cd83730f8ffaf0.zip
dev-python/psycopg: Bump to 3.1.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-3.1.13.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 3d1cca902c4b..f52294329416 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,4 +1,5 @@
DIST psycopg-3.1.10.gh.tar.gz 490875 BLAKE2B 26b82aa34f0eecc3e15943390b74d82e838415564f96d6d11c65d2d705045f78231d7a0275bc74b6a1e095210d249aaaa2e2e59debd4c19cdcfbe348fe598b95 SHA512 37d1d2cbe3956862d3dbecd50505267f89a837e42e188e7ff7295c4e5e0d480efd86019ce5a88cd9b682075e2e99ec9037f83de42cb1f5dbcc370a8d3c90a474
DIST psycopg-3.1.12.gh.tar.gz 496491 BLAKE2B df70ae76cb740cbeb313925fafd23650a5d9cb584cb79409eb55ab73260c698758c78878bfa0fbe6c6f1b6f8e55fb91290403246360776176be1fdb758d7361d SHA512 52489337ee4bfc4fe3070a731661264238646f50c86ecf9b4c902da1ab050b2ba6a8f8d1322b0f57f368d3c93f7ec3dd59f7970319e2df8eb52c728a5d7fecc1
+DIST psycopg-3.1.13.gh.tar.gz 500475 BLAKE2B c00176335808ba0fb15dc23fd93e394926517cb2c7e072a35ba909b0b1b128bdecf8305ae1d4e494a5b1f04fee28e98b862ef9f10bd152de6eb9a8e73cf8b5dc SHA512 489ea9f562be6aaaa81b8c96e47b65a1ec0f2f59587f7dc931744d9f6faede1b068fd6e464f530096cac276e1f73e99f069aaab5bd2c3955aa2e0511699659f3
DIST psycopg2-2.9.4.tar.gz 384017 BLAKE2B 4bc0afcc890c8a257c1ccd5c6e4e5301857a80f8b1428aa46c1473c9e18f5d2914a2e592c13336b06106217bb334d9b0321835bdd123f1627cbeb29dedf97bf7 SHA512 259088e42e0ab0d8a1a0ccf04f5e560f32c6179b4a0a0059e91bcf269baa8f4b0f1f949c332c640a2438c927a29b2c144078a861f8e18ba9c764da7c93c73b8d
DIST psycopg2-2.9.9.tar.gz 384926 BLAKE2B 8418fca1329703cedfc86be74d85cae5133a0604bb8a21fa43e5359a46626d38ef227d0cd8fbbeb497e2db517a469d7f3e86b74ef9163617a547e999073a6b4c SHA512 a691fd09762221e854861dedce37b05e5354e0701feea470a6d5046960056ef02a8c9ecfa751adeba485271ea7d5834643b7d3a3c3f3270087f5ed9c68509f5f
diff --git a/dev-python/psycopg/psycopg-3.1.13.ebuild b/dev-python/psycopg/psycopg-3.1.13.ebuild
new file mode 100644
index 000000000000..9e575cdc3f54
--- /dev/null
+++ b/dev-python/psycopg/psycopg-3.1.13.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="
+ https://www.psycopg.org/psycopg3/
+ https://github.com/psycopg/psycopg/
+ https://pypi.org/project/psycopg/
+"
+SRC_URI="
+ https://github.com/psycopg/psycopg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/psycopg
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DEPEND="
+ >=dev-db/postgresql-8.1:*
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-db/postgresql-8.1[server]
+ <dev-python/anyio-4[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # tests are lurking in top-level directory
+ cd .. || die
+
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" test || die
+
+ local -x PSYCOPG_TEST_DSN="host=${T} dbname=test"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # tests for the psycopg_pool package
+ tests/pool
+ # some broken mypy magic
+ tests/test_module.py::test_version
+ tests/test_module.py::test_version_c
+ tests/test_typing.py
+ tests/crdb/test_typing.py
+ # TODO, relying on undefined ordering in Python?
+ tests/test_dns_srv.py::test_srv
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # leak and timing tests are fragile whereas slow tests are slow
+ epytest -p anyio -k "not leak" -m "not timing and not slow"
+}