summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-23 22:22:29 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-23 22:38:58 +0200
commitba63641a013dbfc8904e33a9790c675bed23fc72 (patch)
treeed33b5cc26c9daa3311e5b97412c6588b0c6d688
parentsci-mathematics/coq-serapi: bump to 0.18.1 (diff)
downloadgentoo-ba63641a013dbfc8904e33a9790c675bed23fc72.tar.gz
gentoo-ba63641a013dbfc8904e33a9790c675bed23fc72.tar.bz2
gentoo-ba63641a013dbfc8904e33a9790c675bed23fc72.zip
app-emacs/citar: bump to 1.4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/citar/Manifest1
-rw-r--r--app-emacs/citar/citar-1.4.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
index 826e615e2d50..3116798a392e 100644
--- a/app-emacs/citar/Manifest
+++ b/app-emacs/citar/Manifest
@@ -1 +1,2 @@
DIST citar-1.3.1.tar.gz 1602843 BLAKE2B 0abf90120860777e13ac495681bb1e07d6c352bc17aef173b32e60fc2d754a37628670b57e17335bc5e549c451b9565a58c8547952a5b78d6335adc7601b8f5e SHA512 a00e7ff5331fa3a161151292dd4a9d3c0a7211051f5ddf528cfe7d4a48377af64f3719f57c76013b45a30082fbfd435d98196e757169970a22bb662f49ccd346
+DIST citar-1.4.0.tar.gz 1604664 BLAKE2B 26ebe97a6701fa8c8d528ad0c6d750ea5acebda1fe6322c157fe62995140a9b3f16274888e51110a01dbd1681d7552637bc230d5d1e95270157bc524c037d7da SHA512 42ddb8eec21ad8c53b77b5ee235cd839fdb8d3a3efef8db28effd2bfc63d1d25c1031abb21df476e0243c99aaa619c2d1f29142f5569deb06281774c960924a9
diff --git a/app-emacs/citar/citar-1.4.0.ebuild b/app-emacs/citar/citar-1.4.0.ebuild
new file mode 100644
index 000000000000..1e1644827e32
--- /dev/null
+++ b/app-emacs/citar/citar-1.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}