summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-08-19 19:38:01 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-20 07:36:09 +0100
commitba67378034a0e8c36e0b6af7cbf9f63d3b82c5be (patch)
tree5a31980e827131a9d2bdcbb31744b58c6ef37dd5
parentdev-haskell/optparse-simple: remove old (diff)
downloadgentoo-ba673780.tar.gz
gentoo-ba673780.tar.bz2
gentoo-ba673780.zip
dev-lang/erlang: remove unused patches
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17172 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-lang/erlang/files/erlang-20.3.2-dont-ignore-LDFLAGS.patch42
-rw-r--r--dev-lang/erlang/files/erlang-add-epmd-pid-file-creation-for-openrc.patch90
-rw-r--r--dev-lang/erlang/files/erlang-custom-autoconf.patch14
3 files changed, 0 insertions, 146 deletions
diff --git a/dev-lang/erlang/files/erlang-20.3.2-dont-ignore-LDFLAGS.patch b/dev-lang/erlang/files/erlang-20.3.2-dont-ignore-LDFLAGS.patch
deleted file mode 100644
index 32dd89e0d6c7..000000000000
--- a/dev-lang/erlang/files/erlang-20.3.2-dont-ignore-LDFLAGS.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 69043168302ec7c0bcfaa8b1fb56bfae500bd139 Mon Sep 17 00:00:00 2001
-From: Nick Sarnie <commendsarnex@gmail.com>
-Date: Sun, 8 Apr 2018 16:11:55 -0400
-Subject: [PATCH] Don't ignore LDFLAGS
-
-Bug: https://bugs.gentoo.org/263129
-
-Signed-off-by: Nick Sarnie <commendsarnex@gmail.com>
----
- lib/megaco/src/flex/Makefile.in | 2 +-
- lib/odbc/c_src/Makefile.in | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/lib/megaco/src/flex/Makefile.in b/lib/megaco/src/flex/Makefile.in
-index c37ad4d702..400024ca0c 100644
---- a/lib/megaco/src/flex/Makefile.in
-+++ b/lib/megaco/src/flex/Makefile.in
-@@ -66,7 +66,7 @@ endif
- CC = $(DED_CC)
- CFLAGS_MT = $(CFLAGS) $(DED_THR_DEFS)
- LD = $(DED_LD)
--LDFLAGS = $(DED_LDFLAGS)
-+LDFLAGS += $(DED_LDFLAGS)
- LEX = @LEX@
- LEXLIB = @LEXLIB@
- PERL = @PERL@
-diff --git a/lib/odbc/c_src/Makefile.in b/lib/odbc/c_src/Makefile.in
-index 784e73c47e..51c023f710 100644
---- a/lib/odbc/c_src/Makefile.in
-+++ b/lib/odbc/c_src/Makefile.in
-@@ -82,7 +82,7 @@ CC = @CC@
- CFLAGS = $(TYPEFLAGS) @CFLAGS@ @THR_DEFS@ @DEFS@
- EI_LDFLAGS = -L$(EI_ROOT)/obj$(TYPEMARKER)/$(TARGET)
- LD = @LD@
--LDFLAGS = $(ODBC_LIB) $(EI_LDFLAGS)
-+LDFLAGS += $(ODBC_LIB) $(EI_LDFLAGS)
- LIBS = @LIBS@ @THR_LIBS@ $(EI_LIB)
- INCLUDES = -I. $(ODBC_INCLUDE) $(EI_INCLUDE)
- TARGET_FLAGS = @TARGET_FLAGS@
---
-2.17.0
-
diff --git a/dev-lang/erlang/files/erlang-add-epmd-pid-file-creation-for-openrc.patch b/dev-lang/erlang/files/erlang-add-epmd-pid-file-creation-for-openrc.patch
deleted file mode 100644
index 56e3946c93fa..000000000000
--- a/dev-lang/erlang/files/erlang-add-epmd-pid-file-creation-for-openrc.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From 04ace92c33a699f75445dc99c30d521311aba826 Mon Sep 17 00:00:00 2001
-From: Steve Arnold <nerdboy@gentoo.org>
-Date: Mon, 6 Aug 2018 16:38:30 -0700
-Subject: [PATCH] Add daemon-mode pid file creation when not configured for
- systemd
-
-Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
----
- erts/epmd/src/epmd.c | 39 ++++++++++++++++++++++++++++++++++++++-
- erts/epmd/src/epmd.h | 3 +++
- 2 files changed, 41 insertions(+), 1 deletion(-)
-
-diff --git a/erts/epmd/src/epmd.c b/erts/epmd/src/epmd.c
-index 44e997e609..c74888a1ee 100644
---- a/erts/epmd/src/epmd.c
-+++ b/erts/epmd/src/epmd.c
-@@ -40,6 +40,37 @@ static int check_relaxed(void);
- #ifdef __WIN32__
- static int has_console(void);
- #endif
-+#ifndef HAVE_SYSTEMD_DAEMON
-+static int create_pidfile(void);
-+static const char *pidfile = EPMD_PIDFILE;
-+#endif
-+
-+#ifndef HAVE_SYSTEMD_DAEMON
-+static int create_pidfile(void)
-+{
-+ int fd;
-+
-+ unlink(pidfile);
-+
-+ /* open the pidfile */
-+ fd = open(pidfile, O_WRONLY|O_CREAT|O_EXCL, 0644);
-+ if (fd >= 0) {
-+ FILE *f;
-+
-+ /* write our pid to it */
-+ f = fdopen(fd, "w");
-+ if (f != NULL) {
-+ fprintf(f, "%d\n", getpid());
-+ fclose(f);
-+ /* leave the fd open */
-+ return 0;
-+ }
-+ close(fd);
-+ }
-+
-+ return -1;
-+}
-+#endif /* (no) HAVE_SYSTEMD_DAEMON */
-
- #ifdef DONT_USE_MAIN
-
-@@ -340,6 +371,13 @@ static void run_daemon(EpmdVars *g)
-
- umask(0);
-
-+#ifndef HAVE_SYSTEMD_DAEMON
-+ if (create_pidfile() < 0) {
-+ dbg_perror(g,"could not create pidfile %s", pidfile);
-+ epmd_cleanup_exit(g,1);
-+ }
-+#endif /* HAVE_SYSTEMD_DAEMON */
-+
- for (fd = 0; fd < g->max_conn ; fd++) /* close all files ... */
- close(fd);
- /* Syslog on linux will try to write to whatever if we dont
-@@ -614,4 +652,3 @@ static int check_relaxed(void)
- char* port_str = getenv("ERL_EPMD_RELAXED_COMMAND_CHECK");
- return (port_str != NULL) ? 1 : 0;
- }
--
-diff --git a/erts/epmd/src/epmd.h b/erts/epmd/src/epmd.h
-index cffcd4ae7a..e53322acf5 100644
---- a/erts/epmd/src/epmd.h
-+++ b/erts/epmd/src/epmd.h
-@@ -20,6 +20,9 @@
-
- /* The port number is defined in a makefile */
-
-+/* The name and path to the pid file */
-+#define EPMD_PIDFILE "/var/run/epmd.pid"
-+
- /* Definitions of message codes */
-
- /* Registration and queries */
---
-2.17.0
-
diff --git a/dev-lang/erlang/files/erlang-custom-autoconf.patch b/dev-lang/erlang/files/erlang-custom-autoconf.patch
deleted file mode 100644
index 5ae7b43ba289..000000000000
--- a/dev-lang/erlang/files/erlang-custom-autoconf.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur otp-OTP-21.0.5.orig/otp_build otp-OTP-21.0.5/otp_build
---- otp-OTP-21.0.5.orig/otp_build 2018-08-10 19:02:51.000000000 +0200
-+++ otp-OTP-21.0.5/otp_build 2018-08-15 23:44:59.417191209 +0200
-@@ -1343,7 +1343,9 @@
- do_lazy_configure "$@";
- do_boot;;
- autoconf)
-- do_autoconf;;
-+ create_lib_configure_in
-+ distribute_config_helpers
-+ ;;
- configure)
- shift;
- do_configure "$@";;