summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-25 01:13:14 +0100
committerSam James <sam@gentoo.org>2022-07-25 01:13:14 +0100
commitba85a40760ce3b3c3495a26f56715f33e26f09d7 (patch)
tree3591616dab85eca7622b5c08a4ee867ff8f6324c
parentsys-apps/file: add github upstream metadata (diff)
downloadgentoo-ba85a407.tar.gz
gentoo-ba85a407.tar.bz2
gentoo-ba85a407.zip
sys-apps/logwatch: add 7.7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.7.ebuild93
-rw-r--r--sys-apps/logwatch/logwatch-9999.ebuild20
3 files changed, 104 insertions, 10 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 065b748116b1..e9d045a919d0 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1 +1,2 @@
DIST logwatch-7.6.tar.gz 488750 BLAKE2B fd7f2a7c65151dbfbd924102b01ead00f92d74a59a417361b65be972368f7ed93810feefedf1ad9bba2de5ebbc74589c3fc0a8a484f19b5a9782c9799ffdf656 SHA512 8672dcf2b781d89ec281c4370b204467f9db219edb7c23adf02b71decf0ecab7b442d6e95e91416af3aecc27948e9442bb3b369e532e40f7ef32635628e110af
+DIST logwatch-7.7.tar.gz 498214 BLAKE2B 8978930fe844bde372f68038f295cc62ca61f1c2b10d18f545ddcc713cb72cd01520ff0ea0869f2dff96846431a6dd9a04da1bc79817ccb590b0235f96e934da SHA512 5224013c548e60248ef2de8aeabc760d046374f54035e7e5e00bba0c6e6777eb5e7fcfd05a9f029d3d34e9d3fb8a243ed99b417961b21895cc14b881f1ad3dd4
diff --git a/sys-apps/logwatch/logwatch-7.7.ebuild b/sys-apps/logwatch/logwatch-7.7.ebuild
new file mode 100644
index 000000000000..db6cdabae32a
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit tmpfiles
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo
+ virtual/cron
+ virtual/mta
+ virtual/mailx
+"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else (bug #100243)
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}
diff --git a/sys-apps/logwatch/logwatch-9999.ebuild b/sys-apps/logwatch/logwatch-9999.ebuild
index 13d30026df24..db6cdabae32a 100644
--- a/sys-apps/logwatch/logwatch-9999.ebuild
+++ b/sys-apps/logwatch/logwatch-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
inherit tmpfiles
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
inherit git-r3
else
@@ -19,17 +19,17 @@ HOMEPAGE="https://sourceforge.net/projects/logwatch/"
LICENSE="MIT"
SLOT="0"
-RDEPEND="virtual/cron
- virtual/mta
- virtual/mailx
+RDEPEND="
dev-lang/perl
dev-perl/Date-Calc
dev-perl/Date-Manip
dev-perl/Tie-IxHash
dev-perl/Sys-CPU
- dev-perl/Sys-MemInfo"
-
-PATCHES=()
+ dev-perl/Sys-MemInfo
+ virtual/cron
+ virtual/mta
+ virtual/mailx
+"
src_install() {
dodir /usr/share/logwatch/lib
@@ -66,7 +66,7 @@ src_install() {
insinto /usr/share/logwatch/default.conf/html
doins conf/html/*
- # Make sure logwatch is run before anything else #100243
+ # Make sure logwatch is run before anything else (bug #100243)
exeinto /etc/cron.daily
newexe "${FILESDIR}"/logwatch 00-logwatch