summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2022-09-01 02:08:51 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-09-01 09:27:51 +0300
commitba8d0af76670991b7279541bc0582d1d4885c09e (patch)
tree435756ce7f4a200ecadcc2e8357d972e997c7241
parentsys-kernel/vanilla-kernel: Remove vulnerable versions (diff)
downloadgentoo-ba8d0af76670991b7279541bc0582d1d4885c09e.tar.gz
gentoo-ba8d0af76670991b7279541bc0582d1d4885c09e.tar.bz2
gentoo-ba8d0af76670991b7279541bc0582d1d4885c09e.zip
net-libs/libsearpc: version bump to 3.2.0_p1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-libs/libsearpc/Manifest1
-rw-r--r--net-libs/libsearpc/libsearpc-3.2.0_p1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/libsearpc/Manifest b/net-libs/libsearpc/Manifest
index 7198ca76ba6d..fb2501075b90 100644
--- a/net-libs/libsearpc/Manifest
+++ b/net-libs/libsearpc/Manifest
@@ -1 +1,2 @@
DIST libsearpc-3.2.0.tar.gz 52303 BLAKE2B 34707b504b4e63017549e5ed04e8e1e8d1e98b873aebe2ad3f675fe88e209bb73d8b56d1aef137bc4bead2a2fbcf7410dfdf1d02a92a8f37efbaaf0d56d79a4c SHA512 071784b6d34f6ddf947748474c210f0f803e3451373e351b6a768b0cf4a17ddcdaf415ff4ce5f020f1a68df3f6f0a0e53a78ad9e2df286fafea870e303c8f6dd
+DIST libsearpc-3.2.0_p1.tar.gz 54011 BLAKE2B 9bdfa72b207eb57d1242384e5581eea9083f4f30616a9bc8da1255b281c0a847ec1fc6d23db7510dc7988a67d7c836762b8343ac4fdffe07ce6296b65d9cf8c8 SHA512 2e1580ffa54e233b078385a94d2d9a7e080bfb2f8ccbaf96645c94f86d0eda686bd84277341cff39840afa03fc67abd05cb2f57a81d117fff4773280f9da265a
diff --git a/net-libs/libsearpc/libsearpc-3.2.0_p1.ebuild b/net-libs/libsearpc/libsearpc-3.2.0_p1.ebuild
new file mode 100644
index 000000000000..b9dac0542a45
--- /dev/null
+++ b/net-libs/libsearpc/libsearpc-3.2.0_p1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+# Upstream is moving tags repeatedly, then we use commit hash.
+RELEASE_COMMIT="54145b03f4240222e336a9a2f402e93facefde65" #tag v3.2_latest
+
+inherit autotools python-single-r1
+
+DESCRIPTION="A simple C language RPC framework"
+HOMEPAGE="https://github.com/haiwen/libsearpc/ http://seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/${RELEASE_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/jansson-2.2.1:="
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ ')"
+
+S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" ${PN}.pc.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files
+ find "${ED}" -name '*.la' -delete || die
+}