summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-01-29 19:00:10 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-01-29 19:26:59 +0100
commitba94180ee142466df4de1c45f9b2f15fe6428b67 (patch)
treecc808c1cdeb665b2458aa07108cd09a64e539446
parentx11-plugins/wmCalClock: fix build with -fno-common (diff)
downloadgentoo-ba94180ee142466df4de1c45f9b2f15fe6428b67.tar.gz
gentoo-ba94180ee142466df4de1c45f9b2f15fe6428b67.tar.bz2
gentoo-ba94180ee142466df4de1c45f9b2f15fe6428b67.zip
x11-plugins/wmwork: fix build with -fno-common
Closes: https://bugs.gentoo.org/706688 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmwork/files/wmwork-0.2.5-gcc-10.patch21
-rw-r--r--x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild3
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-plugins/wmwork/files/wmwork-0.2.5-gcc-10.patch b/x11-plugins/wmwork/files/wmwork-0.2.5-gcc-10.patch
new file mode 100644
index 000000000000..3ed8b82f29e8
--- /dev/null
+++ b/x11-plugins/wmwork/files/wmwork-0.2.5-gcc-10.patch
@@ -0,0 +1,21 @@
+--- a/wmgeneral.c
++++ b/wmgeneral.c
+@@ -45,6 +45,7 @@ Window iconwin, win;
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ /*****************/
+ /* Mouse Regions */
+--- a/wmgeneral.h
++++ b/wmgeneral.h
+@@ -21,7 +21,7 @@ typedef struct {
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild b/x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild
index a7d81d4d1ae4..e8fd4e681e82 100644
--- a/x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild
+++ b/x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,3 +20,4 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P}/src"
DOCS=( ../{CHANGES,README} )
+PATCHES=( ${FILESDIR}/${P}-gcc-10.patch )