summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-01 06:35:04 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-01 07:16:12 +0100
commitbaa399a239fd35b672a595c5813af2acb8f7aedf (patch)
tree604a7c15927a4dd70c368f4dfb1c6b40322a2859
parentdev-python/aws-sam-translator: Bump to 1.60.1 (diff)
downloadgentoo-baa399a2.tar.gz
gentoo-baa399a2.tar.bz2
gentoo-baa399a2.zip
dev-python/botocore: Bump to 1.29.81
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.81.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e852f0fe5415..dcae58dcc352 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.29.74.gh.tar.gz 11153254 BLAKE2B b3d3b75643cd5e3fac54a09e971daa23a043ba9f7ab773c2fd57dc15417c1b30c6f503515bad8734332bc40c4210e4ac09566c0742649c6ac3592e81ae9f8d79 SHA512 944ebbf1268fa9e8bb68ce5960da347613bcab585bf54c2fd6dbecb499088c1dc426357cde0a0f0d1780ecbc06acc33d8587f37c7f3d13577283b4549a353406
DIST botocore-1.29.79.gh.tar.gz 11184048 BLAKE2B 062326a477fb27844ec47af28b77424863d6ff407dbcfd95bc9aa26d4009f503364f3d438997fe437b4830b8ef8c7bfb7e026313364bb3e9429cd3b7c2eae261 SHA512 260cf6a533e32c6f514774e5c5ef6830feb77058e1074e730d7fa05fb7067dac093f1a612ed11e02db116671ca9f7301ed29e1625f6e47724301d25b03eb3c30
DIST botocore-1.29.80.gh.tar.gz 11197756 BLAKE2B 62f70c71f6b5892ff4daaede65389c75a159ebc29da69b2b2f9b59fabcf1818d91b968cbb04f48acce8310f34b96dbb30189c1fdc609e124202a6743d5b3e65a SHA512 27f31ba27448c5ea3214dcd585d60901761f6cd26e384a861aa377842dd3561f293c261a6a3fd91e78cc3ea75f48b9369e77f4a8d1a4b4dd08fbdde9335ee5a8
+DIST botocore-1.29.81.gh.tar.gz 11211684 BLAKE2B c89f683ab6fd238f975af4a30eea6191d1a6c2a8cf5ec1ac640a34de801bc289545dc2a98e9a76824afdb650b9d173751b23af3a3f3e9438f8cd1cdeb0fb64e3 SHA512 91b0d34652f68a3f41e768ff35d342c50868fb9e6f9da2b97a64cf08cac03e959395ac499b9fea7cf5997273700b06499f0d870661b9104709fead4a87c0a1ee
diff --git a/dev-python/botocore/botocore-1.29.81.ebuild b/dev-python/botocore/botocore-1.29.81.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.81.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}