summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:57:21 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 11:02:23 +0100
commitbaa5a7dd3177739ed654d65c8fd2fa58be733b50 (patch)
treef4e1b8985a7fe091aae9fabd540b8b51a228ea7b
parentdev-python/url-normalize: Switch to PEP 517 build (diff)
downloadgentoo-baa5a7dd.tar.gz
gentoo-baa5a7dd.tar.bz2
gentoo-baa5a7dd.zip
dev-python/rich: Switch to PEP 517 build in 10* too
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rich/rich-10.16.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/rich/rich-10.16.2-r1.ebuild b/dev-python/rich/rich-10.16.2-r1.ebuild
new file mode 100644
index 000000000000..bd629c2ce249
--- /dev/null
+++ b/dev-python/rich/rich-10.16.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # check for exact color render string, which changes across pygments bumps
+ tests/test_syntax.py::test_python_render
+ tests/test_syntax.py::test_python_render_simple
+ tests/test_syntax.py::test_python_render_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}