summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-08-31 19:13:10 -0400
committerNick Sarnie <sarnex@gentoo.org>2022-08-31 19:22:23 -0400
commitbabe14b4c7b77499367cbdca1e811eec66c573fd (patch)
tree6d26ce80a68bdeae1c243a0c48cb92c617fee241
parentwww-apps/rutorrent: Use EAPI=7 for -9999 package (diff)
downloadgentoo-babe14b4.tar.gz
gentoo-babe14b4.tar.bz2
gentoo-babe14b4.zip
app-emulation/wine-vanilla: Add error for app-emulation/wine-gecko version mismatch
Thanks to sam for basically doing it for me Bug: https://bugs.gentoo.org/866698 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.16.ebuild10
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.16.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.16.ebuild
index acf26429424f..1bb18ebe2ce5 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.16.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.16.ebuild
@@ -10,6 +10,7 @@ inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolcha
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
+GECKO_VERSION="2.47.3"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://source.winehq.org/git/wine.git"
@@ -103,7 +104,7 @@ RDEPEND="${COMMON_DEPEND}
app-emulation/wine-desktop-common
>app-eselect/eselect-wine-0.3
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
- gecko? ( app-emulation/wine-gecko:2.47.3[abi_x86_32?,abi_x86_64?] )
+ gecko? ( app-emulation/wine-gecko:${GECKO_VERSION}[abi_x86_32?,abi_x86_64?] )
mono? ( app-emulation/wine-mono:7.3.0 )
perl? (
dev-lang/perl
@@ -235,6 +236,13 @@ src_prepare() {
done
}
+ if use gecko; then
+ local source_gecko_version=$( sed -n -e '/^#define GECKO_VERSION/p' dlls/appwiz.cpl/addons.c | grep -Eo -m 1 '[0-9.]+' )
+ if [[ ${source_gecko_version} != ${GECKO_VERSION} ]] ; then
+ die "app-emulation/wine-gecko version is not correct! Please file a bug."
+ fi
+ fi
+
local md5="$(md5sum server/protocol.def)"
default
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index acf26429424f..1bb18ebe2ce5 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -10,6 +10,7 @@ inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolcha
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
+GECKO_VERSION="2.47.3"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://source.winehq.org/git/wine.git"
@@ -103,7 +104,7 @@ RDEPEND="${COMMON_DEPEND}
app-emulation/wine-desktop-common
>app-eselect/eselect-wine-0.3
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
- gecko? ( app-emulation/wine-gecko:2.47.3[abi_x86_32?,abi_x86_64?] )
+ gecko? ( app-emulation/wine-gecko:${GECKO_VERSION}[abi_x86_32?,abi_x86_64?] )
mono? ( app-emulation/wine-mono:7.3.0 )
perl? (
dev-lang/perl
@@ -235,6 +236,13 @@ src_prepare() {
done
}
+ if use gecko; then
+ local source_gecko_version=$( sed -n -e '/^#define GECKO_VERSION/p' dlls/appwiz.cpl/addons.c | grep -Eo -m 1 '[0-9.]+' )
+ if [[ ${source_gecko_version} != ${GECKO_VERSION} ]] ; then
+ die "app-emulation/wine-gecko version is not correct! Please file a bug."
+ fi
+ fi
+
local md5="$(md5sum server/protocol.def)"
default