summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-05-04 19:26:32 +0200
committerPacho Ramos <pacho@gentoo.org>2024-05-04 19:38:02 +0200
commitbac8dbb34a738e89b023c4554ab14f8dd5eedd23 (patch)
treed0104c996672da731fbc7ea2631fba9e25adb69a
parentnet-misc/r8168: drop 8.051.02 (diff)
downloadgentoo-bac8dbb34a738e89b023c4554ab14f8dd5eedd23.tar.gz
gentoo-bac8dbb34a738e89b023c4554ab14f8dd5eedd23.tar.bz2
gentoo-bac8dbb34a738e89b023c4554ab14f8dd5eedd23.zip
gnome-extra/gnome-shell-extension-appindicator: add 58
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-58.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/Manifest b/gnome-extra/gnome-shell-extension-appindicator/Manifest
index 42eea5d48a11..a69da1444013 100644
--- a/gnome-extra/gnome-shell-extension-appindicator/Manifest
+++ b/gnome-extra/gnome-shell-extension-appindicator/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-appindicator-53.tar.gz 69263 BLAKE2B a8f4b2d9534bf1711ae47fdc420ac3ca1539efe3963eb4a5fbd9e0ad71e047003ac639c5620e4c849be8a9873dd2b42659dd5883f7703a1d9dd940cc319580a6 SHA512 cc6f88c1dcfaacc47184fbe6a8b7d1525623485f686033d6a817d6d9d597f1a305a75cdbc3c9e7f05145e7ffb305893b2550812b3cb2c97aaf9af7a5399f8441
DIST gnome-shell-extension-appindicator-57.tar.gz 67246 BLAKE2B cdbfce7c2ff731732dea76ce53421424ad887ab7c95b555142f1fccb549723c9f9816cde527dd0dca6b9c6b835d9ec8d255f8350f8d772199920ac69d2d26809 SHA512 256d365a653db40490cb0d4da5ee5f7508298bc9189e0a8e98a4f1c904f5627cd0cb1b5586786005638025e3b8a31bf948d08a69a40977887b5860f8dc5ee53e
+DIST gnome-shell-extension-appindicator-58.tar.gz 68877 BLAKE2B 976310cb6d532adf522c2d51bf04d6c5ee78e76759dbc8ab8965b1c738e5077be26b62e3c25f30b6a6311f98427d88c498ed839c0e401d86f9d701343229ae67 SHA512 94919a1494e354d8ef081fc3b844c092369f0b0928fa94f5677cecede87bff1e8669b6b064e4ed9d40ddb9f536f68075776e5afafb06cc3df33e3b83387ea6f8
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-58.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-58.ebuild
new file mode 100644
index 000000000000..7090304530b4
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-58.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils meson
+
+DESCRIPTION="Support legacy, AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-45
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_prepare() {
+ default
+ # https://github.com/ubuntu/gnome-shell-extension-appindicator/issues/419
+ eapply -R "${FILESDIR}/${PN}-53-41a8e9c.patch"
+}
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}