summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-03 11:16:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-03 12:12:42 +0300
commitbae2ba8963dc97669287e3f993993574383cc398 (patch)
treed8d50d0302d1d914196f9704913a60ab24d4183b
parentxfce-extra/xfce4-pulseaudio-plugin: Bump to 0.4.4 (diff)
downloadgentoo-bae2ba89.tar.gz
gentoo-bae2ba89.tar.bz2
gentoo-bae2ba89.zip
dev-python/atpublic: add 3.1.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/atpublic/Manifest1
-rw-r--r--dev-python/atpublic/atpublic-3.1.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/atpublic/Manifest b/dev-python/atpublic/Manifest
index 1557c5fda80b..8252ac734596 100644
--- a/dev-python/atpublic/Manifest
+++ b/dev-python/atpublic/Manifest
@@ -1,2 +1,3 @@
DIST atpublic-3.0.1.tar.gz 14131 BLAKE2B 3912c23c5ee575d7bdec1b598f1f360c54296211600115a413d97c73751b5301b2f3d22152aa62d4d7ac6da9a6cf4202a2deba1de374407ede4358620ee97391 SHA512 02c4af8aa02040bba2f09b852e17a0a90c0a6dce8fdabc8362a67c2f326b68369bf5f12f91291f9ff3395685530592561b132f09f9869867516592bd092e0e38
+DIST atpublic-3.1.1.tar.gz 14050 BLAKE2B a83bfed40b5073c9aba92e367b9627a86eecb297332631222f86f0cea0f10d6fde8ffd5cbef1e3bd1f9005c1cae614268867e652e33d1bee4556e2084fb8952c SHA512 b34dbb236717b2017de95aa79226f0138e77814a4041e26e98f50db8f8521d81b60f9998aed719e1e1f2ee29a7c590170725e12a54260900ce9819ea3a623dac
DIST atpublic-3.1.tar.gz 14328 BLAKE2B f163eff6e955412586517617fb28cd090fb37fdce013973ccbc539b1ae4c4a3c8511f08b026678a9e0310c8d245cb52c932422de65c2a70293d070387a413cac SHA512 93778e4ab7e109b2692a385bab180bfb709a01f0bbab5c24308635408d4bc6ea37144375b31f81a36288ec7993971e40b67cfd0f545f72b011b86ceb6d108ffe
diff --git a/dev-python/atpublic/atpublic-3.1.1.ebuild b/dev-python/atpublic/atpublic-3.1.1.ebuild
new file mode 100644
index 000000000000..3985ada854dc
--- /dev/null
+++ b/dev-python/atpublic/atpublic-3.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A decorator to populate __all__ and the module globals"
+HOMEPAGE="
+ https://gitlab.com/warsaw/public/
+ https://pypi.org/project/atpublic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/sybil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}