summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-03 19:41:01 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-03 19:49:07 +0200
commitbaf0b9b84769e35dee188e68946759c0b05dda2c (patch)
tree6d4a140ec6c2cee21e48418c953bbcd2be2ad3aa
parentdev-python/jaraco-collections: add 3.5.0 (diff)
downloadgentoo-baf0b9b8.tar.gz
gentoo-baf0b9b8.tar.bz2
gentoo-baf0b9b8.zip
dev-python/sphinx-jinja: add 1.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sphinx-jinja/Manifest1
-rw-r--r--dev-python/sphinx-jinja/sphinx-jinja-1.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinx-jinja/Manifest b/dev-python/sphinx-jinja/Manifest
index ec693dea6748..ced46ac0ff57 100644
--- a/dev-python/sphinx-jinja/Manifest
+++ b/dev-python/sphinx-jinja/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-jinja-1.1.0.tar.gz 7306 BLAKE2B 17b8df65f32e0b39eeed406b9bd71974a2b4399154b6d3bf13d9011c0d415b856345ec2fffff8fed39f893b7adb5fa1c012ebf80319ac6af74739e7fe9372229 SHA512 acbe1c2f2044b8e202db60a9964c509a33206c113ca2833dc43bb4849bc91e26b0c84959d8c8f2e5331c33c2e9de73c0348a3841740a5b7d260a43bf4876949f
DIST sphinx-jinja-1.2.1.gh.tar.gz 16963 BLAKE2B 6ec67c6e212fa9e99705c02633416d1397a5ae36dc66984f2839609b9924930b6b5b49ff56b0b712f1326f6651f44d2ba3a15c0061cb6131517f6a463b12552b SHA512 31905aef35b87e5b44bc777a5bd01c5b9fe9350c849b918407710a6b75e26a1f217cd2524874ebb2b97c20c53c4f3fd678b1f166f8100eb81b489f23d114d24b
+DIST sphinx-jinja-1.4.0.gh.tar.gz 17768 BLAKE2B dec2f78020603882c45427f34a336537394d9c3454a6fa021969c8ea2ba0fa297be32565c7afd3f061c8ffeb644e86d8ede935222b3f71419d09038b213b70c8 SHA512 7762b38fa1bf8c7d6a2910aab6c8c80f8df446754f311375cff4c0d6c163bcde10475c2eb7fe2892bac1ab4c24d92984e96fbcdba65c2be100668247a7987c05
diff --git a/dev-python/sphinx-jinja/sphinx-jinja-1.4.0.ebuild b/dev-python/sphinx-jinja/sphinx-jinja-1.4.0.ebuild
new file mode 100644
index 000000000000..02b1b2f7a625
--- /dev/null
+++ b/dev-python/sphinx-jinja/sphinx-jinja-1.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension to include jinja based templates into a sphinx doc"
+HOMEPAGE="https://github.com/tardyp/sphinx-jinja https://pypi.org/project/sphinx-jinja/"
+SRC_URI="
+ https://github.com/tardyp/sphinx-jinja/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install() {
+ # Avoid namespace collision: bug #829747
+ rm "${BUILD_DIR}"/lib/sphinxcontrib/__init__.py || die
+ distutils-r1_python_install
+}