summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-06-11 22:46:43 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-08-05 11:12:13 +0200
commitbb28089c978a7c461bbfde980e1e912e60f14a9b (patch)
treee4536471a61382285555790bc10106d6f8b057f0
parentprofiles: masked packages for removal (diff)
downloadgentoo-bb28089c978a7c461bbfde980e1e912e60f14a9b.tar.gz
gentoo-bb28089c978a7c461bbfde980e1e912e60f14a9b.tar.bz2
gentoo-bb28089c978a7c461bbfde980e1e912e60f14a9b.zip
dev-python/zict: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-python/zict/Manifest1
-rw-r--r--dev-python/zict/zict-0.1.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/zict/Manifest b/dev-python/zict/Manifest
index 7a0098a5ee18..5160f2f891de 100644
--- a/dev-python/zict/Manifest
+++ b/dev-python/zict/Manifest
@@ -1,2 +1,3 @@
DIST zict-0.1.2.tar.gz 10839 BLAKE2B 6256e6202f6cca1db025d21c42b98163ad897ceda6a1b878e75165b358ec0a4b9150f04ecdc05f5408dd74c97212b8301d1f45d91f92dad138789570ffcfa562 SHA512 13fc6647bc1506bc5e8f69d39a07851a06634949ce917f294762ff3143c8a539117f8731b103df2663708fa1e8c968359985d9c4273aa952f500a89019c176e3
DIST zict-0.1.3.tar.gz 11199 BLAKE2B f91c51888816b3b3693ee272379e36c58141afeba14cf25eff9e1416cd59900ca9ab146d7fe806a22939e97dfb3f1657e443eb1420f4d5170a3723df32c3d73b SHA512 2051ff589f9dfc822ceb6a0adebb62e7b782bd426be5035163e78031814927dca221bfcc27ce47fb3d0287b1ec7e1ff120ccebf150e447df213aaa2136f744a4
+DIST zict-0.1.4.tar.gz 11335 BLAKE2B 30a70f04328762687ea9e6805e540469c26a85898278f2d83e1004d2663cd728a03df68e4900cf22b9d3b3ec6efc44a0fae3e5e0ff631a8bb8cc1d8ac510b8ee SHA512 3381c7fd64a99145f80800772dde381ae16225209aa9300f9d1a2c36b5ac1c4281d4068202e607985666ad44cce7d18317d4d8ca4d3ea4f9a227d4f4180e015c
diff --git a/dev-python/zict/zict-0.1.4.ebuild b/dev-python/zict/zict-0.1.4.ebuild
new file mode 100644
index 000000000000..7c2c1e3d994b
--- /dev/null
+++ b/dev-python/zict/zict-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mutable mapping tools"
+HOMEPAGE="https://github.com/dask/zict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/HeapDict[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/HeapDict[${PYTHON_USEDEP}]
+ dev-python/lmdb[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test || die
+}