summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-15 13:32:25 +0100
committerSam James <sam@gentoo.org>2022-07-15 13:32:47 +0100
commitbb3bdd3212b7973b57cf03f5db36f85050b951de (patch)
tree818da067b2c1372cac6dbc8e5087dedbd8c33451
parentdev-libs/pigpio: tidy PYTHON_COMPAT (diff)
downloadgentoo-bb3bdd3212b7973b57cf03f5db36f85050b951de.tar.gz
gentoo-bb3bdd3212b7973b57cf03f5db36f85050b951de.tar.bz2
gentoo-bb3bdd3212b7973b57cf03f5db36f85050b951de.zip
x11-misc/skippy: update EAPI 7 -> 8; fix build w/ newer imlib2
Closes: https://bugs.gentoo.org/828943 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-misc/skippy/files/skippy-0.5.0-imlib2-pkg-config.patch14
-rw-r--r--x11-misc/skippy/skippy-0.5.0-r2.ebuild47
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/skippy/files/skippy-0.5.0-imlib2-pkg-config.patch b/x11-misc/skippy/files/skippy-0.5.0-imlib2-pkg-config.patch
new file mode 100644
index 000000000000..c109b4e31860
--- /dev/null
+++ b/x11-misc/skippy/files/skippy-0.5.0-imlib2-pkg-config.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/828943
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,8 @@
+ PREFIX = /usr
+ BINDIR = ${PREFIX}/bin
+
+-CFLAGS += `imlib2-config --cflags` `${PKG_CONFIG} xft --cflags` -pedantic -Wall
+-LDLIBS = -lX11 -lm `imlib2-config --libs` `${PKG_CONFIG} xft --libs`
++CFLAGS += `${PKG_CONFIG} --cflags imlib2` `${PKG_CONFIG} xft --cflags` -pedantic -Wall
++LDLIBS = -lX11 -lm `${PKG_CONFIG} --libs imlib2` `${PKG_CONFIG} xft --libs`
+
+ # Comment these out to disable Xinerama support
+ CFLAGS += -DXINERAMA
diff --git a/x11-misc/skippy/skippy-0.5.0-r2.ebuild b/x11-misc/skippy/skippy-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..51f0174ed446
--- /dev/null
+++ b/x11-misc/skippy/skippy-0.5.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A full-screen task-switcher providing Apple Expose-like functionality"
+HOMEPAGE="http://thegraveyard.org/skippy.php"
+SRC_URI="http://thegraveyard.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-pointer-size.patch
+ "${FILESDIR}"/${P}-Makefile.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-imlib2-pkg-config.patch
+)
+
+DOCS=( CHANGELOG skippyrc-default )
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+pkg_postinst() {
+ elog
+ elog "You should copy skippyrc-default from /usr/share/doc/${PF} to"
+ elog "~/.skippyrc and edit the keysym used to invoke skippy."
+ elog "Use x11-apps/xev to find out the keysym."
+ elog
+}