summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-13 19:50:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-13 19:50:29 +0100
commitbb51708e8b4ba90ef878b0612a90ead4741ec2e8 (patch)
tree84398c9590b07a26f597fc9e09e9f3d4ac6059e3
parentdev-python/whatthepatch: Bump to 1.0.3 (diff)
downloadgentoo-bb51708e8b4ba90ef878b0612a90ead4741ec2e8.tar.gz
gentoo-bb51708e8b4ba90ef878b0612a90ead4741ec2e8.tar.bz2
gentoo-bb51708e8b4ba90ef878b0612a90ead4741ec2e8.zip
dev-python/sphinxcontrib-spelling: Bump to 7.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.7.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index a0350632e425..f4edfe2ff6fa 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-spelling-7.6.2.tar.gz 57029 BLAKE2B 0e4cbdb167afbb5e2b60e8bae7e3b3ca8993e32495e5005e3889e8e34199f76deca8e1414e7a702b20a1c2600b9cc56781fa358a707eb1949e2491fe400aff70 SHA512 ab320b442727770ee86e1007bfda62799eb82e851a4dff48613be1bb597148255a0067d99ec4b6de912f1c46f466c691cab175bef98af501a166974946c1e8ae
+DIST sphinxcontrib-spelling-7.7.0.tar.gz 57444 BLAKE2B 22491369888d632cf158013cb3634e110f3c6a34c59e410a10081f5d1857b85b66f62caf8987058c133f80a8230733fc6e749404207503f0b2441a152fdd5118 SHA512 3599e2d0bcb9bf908b3e6f41184256114e4ab5378543be8bfdd4f55dca249c4feb4fbfda8db4495acfa72fd9ac6c416a0c988f5d30f530eb8deebbcee5833245
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.7.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.7.0.ebuild
new file mode 100644
index 000000000000..834977197c58
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+ epytest tests
+}