summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-02-24 18:06:10 +0100
committerSebastian Pipping <sping@gentoo.org>2018-02-24 18:06:10 +0100
commitbb77fdf6d3b93d86963ea317a9abd62b11ac36ea (patch)
treec57fb9b0dd4aa70ad65b07512a6830395d07cef4
parentwww-apps/drupal: Drop old vulnerable versions. (diff)
downloadgentoo-bb77fdf6d3b93d86963ea317a9abd62b11ac36ea.tar.gz
gentoo-bb77fdf6d3b93d86963ea317a9abd62b11ac36ea.tar.bz2
gentoo-bb77fdf6d3b93d86963ea317a9abd62b11ac36ea.zip
app-text/dvisvgm: 2.3.3
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-2.3.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index 81a5c70afae5..62e731506038 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -6,4 +6,5 @@ DIST dvisvgm-2.2.3.tar.gz 2813537 BLAKE2B 0cc2625c779d22dceef8b26c0e977086601f24
DIST dvisvgm-2.2.tar.gz 2841354 BLAKE2B 713257347b258338b8ebf408ee6affddef4a53b51621496cb64638e295a27f90ea03f6d752b692f609429f1e5220363f866e4bbff3e82de1f4a03494ded3052e SHA512 310b3272f41d3378ddfb5663d4b6906f7b1cd1dfbbcff0ad249b27c5c37290c5eb496ec84a536f3166a51de4708f6069da9c6811bb7fc9e667d00b1c3aaafd53
DIST dvisvgm-2.3.1.tar.gz 2854014 BLAKE2B 7df3090e53e5ea11338b5d439f52fad0aecb0658e048792565239fb6121ac05605dd992f9dcaefcc1cfad2c35d0194abdad66173d6c4b9199ab926bb02d93ad9 SHA512 ea105c343bc37b178afca41a20a167fac52341083881866585c12d965961cbbcd3f1580dcb5d5c8b42326c0872b2513bc9d5763942dd2631dd404097ea3b26a6
DIST dvisvgm-2.3.2.tar.gz 2805466 BLAKE2B 45f82ed650bd18d4ee17bd4ef7df778503e90955a509ce1172a131ae79c6842a478af5911b90fa9f6cd537ba7245a317ac188159bcdd9d77dcf32746f1c1781a SHA512 a4b4ed978ce940eb918b3d053dddec1eac20cf9f6abb68de24c94ea2762d473004eb64a0dfca40b4cb7d5b208c70132ad8eea617533f83e46282ee405c9c5939
+DIST dvisvgm-2.3.3.tar.gz 2805568 BLAKE2B 9823d2a8d3b736dfbbfbe0e5d51fb20bf61b4a8d236cc24fadd6e8a918f8f8305dedc23f6d7146574f9302a006a50e33621d350425e1b3c65d780d1354e7b239 SHA512 1b170b5979049f30aaaa5a85d8b5555e87a7af987298980d25c77aebd95b6be56a8518986b8a6eb2215b6dbd32dfbdfdcecb0c81f9d5ffa856370da1b324ed18
DIST dvisvgm-2.3.tar.gz 2816291 BLAKE2B 3c804b49d9a5447063cd70646d0c6bdb56bf7f457aa84a4ef535341e2b5b9bea2b3dbb3209c3afebb5ebaea04300b5784b25ed244145a1afd6a8a4974326c914 SHA512 b1efc505db2c52471306eca099285c35685cf92d0f084a46daa476423d3706a2a3260584f9fdcc5722630a49b4178c9bd36d6cd8019a5b4c9f3759468e8e8313
diff --git a/app-text/dvisvgm/dvisvgm-2.3.3.ebuild b/app-text/dvisvgm/dvisvgm-2.3.3.ebuild
new file mode 100644
index 000000000000..e2eec8fc99a8
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-2.3.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="http://dvisvgm.bplaced.net/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+# Tests don't work from $WORKDIR: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+# TODO unbundle app-arch/brotli
+RDEPEND="virtual/tex-base
+ app-text/ghostscript-gpl
+ dev-libs/kpathsea:=
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ dev-libs/kpathsea
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/xmlto
+ app-text/asciidoc
+ dev-libs/libxslt
+ virtual/pkgconfig
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local myargs=(
+ --without-ttfautohint
+ )
+ econf "${myargs[@]}"
+}