summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2019-08-07 11:49:34 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-10 08:56:01 +0300
commitbb7f219c99bd6dfcac19d0d88dbfe106132c1173 (patch)
tree4e23bf7607200b4cbbf099772c30d2ea0f18f1d0
parentsys-kernel/pf-sources: bump to 5.2-pf5 (diff)
downloadgentoo-bb7f219c.tar.gz
gentoo-bb7f219c.tar.bz2
gentoo-bb7f219c.zip
mail-mta/netqmail: fix build without ssl
Closes: https://bugs.gentoo.org/649854 Closes: https://bugs.gentoo.org/674688 Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Closes: https://github.com/gentoo/gentoo/pull/12630 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--mail-mta/netqmail/netqmail-1.06-r4.ebuild14
-rw-r--r--mail-mta/netqmail/netqmail-1.06-r5.ebuild16
-rw-r--r--mail-mta/netqmail/netqmail-1.06-r6.ebuild16
3 files changed, 26 insertions, 20 deletions
diff --git a/mail-mta/netqmail/netqmail-1.06-r4.ebuild b/mail-mta/netqmail/netqmail-1.06-r4.ebuild
index 1f750f0f1717..aa64d3d57d5e 100644
--- a/mail-mta/netqmail/netqmail-1.06-r4.ebuild
+++ b/mail-mta/netqmail/netqmail-1.06-r4.ebuild
@@ -101,12 +101,14 @@ src_prepare() {
ht_fix_file Makefile*
if ! use vanilla; then
- # This patch contains relative paths and needs to be cleaned up.
- sed 's~^--- ../../~--- ~g' \
- <"${DISTDIR}"/${QMAIL_TLS_F} \
- >"${T}"/${QMAIL_TLS_F} || die
- use ssl && epatch "${T}"/${QMAIL_TLS_F}
- use ssl && epatch "${DISTDIR}"/${QMAIL_TLS_CVE}
+ if use ssl; then
+ # This patch contains relative paths and needs to be cleaned up.
+ sed 's~^--- ../../~--- ~g' \
+ < "${DISTDIR}"/${QMAIL_TLS_F} \
+ > "${T}"/${QMAIL_TLS_F} || die
+ epatch "${T}"/${QMAIL_TLS_F}
+ epatch "${DISTDIR}"/${QMAIL_TLS_CVE}
+ fi
use highvolume && epatch "${DISTDIR}"/${QMAIL_BIGTODO_F}
if use qmail-spp; then
diff --git a/mail-mta/netqmail/netqmail-1.06-r5.ebuild b/mail-mta/netqmail/netqmail-1.06-r5.ebuild
index 31387c27673a..f6f4cfb3deec 100644
--- a/mail-mta/netqmail/netqmail-1.06-r5.ebuild
+++ b/mail-mta/netqmail/netqmail-1.06-r5.ebuild
@@ -105,12 +105,14 @@ src_prepare() {
ht_fix_file Makefile*
if ! use vanilla; then
- # This patch contains relative paths and needs to be cleaned up.
- sed 's~^--- ../../~--- ~g' \
- <"${DISTDIR}"/${QMAIL_TLS_F} \
- >"${T}"/${QMAIL_TLS_F} || die
- use ssl && epatch "${T}"/${QMAIL_TLS_F}
- use ssl && epatch "${DISTDIR}"/${QMAIL_TLS_CVE}
+ if use ssl; then
+ # This patch contains relative paths and needs to be cleaned up.
+ sed 's~^--- ../../~--- ~g' \
+ < "${DISTDIR}"/${QMAIL_TLS_F} \
+ > "${T}"/${QMAIL_TLS_F} || die
+ epatch "${T}"/${QMAIL_TLS_F}
+ epatch "${DISTDIR}"/${QMAIL_TLS_CVE}
+ fi
use highvolume && epatch "${DISTDIR}"/${QMAIL_BIGTODO_F}
if use qmail-spp; then
@@ -127,7 +129,7 @@ src_prepare() {
cd "${WORKDIR}" || die
epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
- epatch "${FILESDIR}"/qmail-smtputf8.patch
+ use ssl && epatch "${FILESDIR}"/qmail-smtputf8.patch
cd - || die
qmail_src_postunpack
diff --git a/mail-mta/netqmail/netqmail-1.06-r6.ebuild b/mail-mta/netqmail/netqmail-1.06-r6.ebuild
index ea0d2b7b10ce..f78baf94aacb 100644
--- a/mail-mta/netqmail/netqmail-1.06-r6.ebuild
+++ b/mail-mta/netqmail/netqmail-1.06-r6.ebuild
@@ -105,12 +105,14 @@ src_prepare() {
ht_fix_file Makefile*
if ! use vanilla; then
- # This patch contains relative paths and needs to be cleaned up.
- sed 's~^--- ../../~--- ~g' \
- <"${DISTDIR}"/${QMAIL_TLS_F} \
- >"${T}"/${QMAIL_TLS_F} || die
- use ssl && epatch "${T}"/${QMAIL_TLS_F}
- use ssl && epatch "${DISTDIR}"/${QMAIL_TLS_CVE}
+ if use ssl; then
+ # This patch contains relative paths and needs to be cleaned up.
+ sed 's~^--- ../../~--- ~g' \
+ < "${DISTDIR}"/${QMAIL_TLS_F} \
+ > "${T}"/${QMAIL_TLS_F} || die
+ epatch "${T}"/${QMAIL_TLS_F}
+ epatch "${DISTDIR}"/${QMAIL_TLS_CVE}
+ fi
use highvolume && epatch "${DISTDIR}"/${QMAIL_BIGTODO_F}
if use qmail-spp; then
@@ -127,7 +129,7 @@ src_prepare() {
cd "${WORKDIR}" || die
epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
- epatch "${FILESDIR}"/qmail-smtputf8.patch
+ use ssl && epatch "${FILESDIR}"/qmail-smtputf8.patch
cd - || die
qmail_src_postunpack