summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-07 05:13:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-07 05:13:52 +0100
commitbb8fa3b51bc751644b4aaa95878afe5721c0ce91 (patch)
treed1afd3ffe5b1283ead51a005666bc71124711a3f
parentdev-python/pkginfo: Bump to 1.9.5 (diff)
downloadgentoo-bb8fa3b5.tar.gz
gentoo-bb8fa3b5.tar.bz2
gentoo-bb8fa3b5.zip
dev-python/reedsolomon: Bump to 1.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/reedsolomon/Manifest1
-rw-r--r--dev-python/reedsolomon/reedsolomon-1.6.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/reedsolomon/Manifest b/dev-python/reedsolomon/Manifest
index 3c352a15bda8..e2e019b5a033 100644
--- a/dev-python/reedsolomon/Manifest
+++ b/dev-python/reedsolomon/Manifest
@@ -1,2 +1,3 @@
DIST reedsolomon-1.5.4.tar.gz 283778 BLAKE2B 5354b8d320db1533469ae1fd706c0412a81bb408675041af5dbf42b42014e4b779b937fa8e3b3d0a5e67e62d9fd7ce9ac519022dd98dbc82a156ee0cda7914ce SHA512 c738f817c8f536ee86e5bcd3de73a4cf6a3e606ba196a359b6c09e7372dba31316ddb8b134d7c335100e4c2ff0158ff07caa35fee9bc20768bde23cd803e274a
DIST reedsolomon-1.6.0.gh.tar.gz 62527 BLAKE2B 100e0152ca8d05605f961dbddcc41552941356a72b488375cb1237cf45938382abf6bfd439b572a9aed11a12068258027fae0bc867e7577280829779d21f53a3 SHA512 ddf73b0bdc78856d9aa76e7bf3fcb9715b9b7f922c2d72dc4bd13a4d5a233844757e2946ef96c545ab7979bc6b62a1f33286711f927871a6689a269d20a81b44
+DIST reedsolomon-1.6.1.gh.tar.gz 63944 BLAKE2B 58845e726fdf2096af280bf14feb981d883b2368a47904d33a2386db0fb5d94091ecdc22e48bfa415e2abd9c4b3c99446b3b51bca9cce510961172697a273a0d SHA512 323f91e3e43847023f23087e1038ae240572b87c29ee26be1a05a6ee49824aa86cb706d1856b27e28841fbb14efaf897d1b8e0cb626529fe7cdeaa7fbda6ce27
diff --git a/dev-python/reedsolomon/reedsolomon-1.6.1.ebuild b/dev-python/reedsolomon/reedsolomon-1.6.1.ebuild
new file mode 100644
index 000000000000..9dad1d4feb55
--- /dev/null
+++ b/dev-python/reedsolomon/reedsolomon-1.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Reed Solomon encoder/decoder"
+HOMEPAGE="
+ https://github.com/tomerfiliba/reedsolomon/
+ https://pypi.org/project/reedsolo/
+"
+SRC_URI="
+ https://github.com/tomerfiliba/reedsolomon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Unlicense" # or MIT-0
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_creedsolo.py || die "creedsolo test failed with ${EPYTHON}"
+ "${EPYTHON}" tests/test_reedsolo.py || die "reedsolo test failed with ${EPYTHON}"
+}