summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-12-20 09:41:19 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-12-20 09:52:31 +0100
commitbb93dcc370fa74e2fc06aeceb6dda8276212826c (patch)
tree0c49d87acc72e289b609ebae45829912f898cb02
parentx11-plugins/wmifs: add 1.9 (diff)
downloadgentoo-bb93dcc370fa74e2fc06aeceb6dda8276212826c.tar.gz
gentoo-bb93dcc370fa74e2fc06aeceb6dda8276212826c.tar.bz2
gentoo-bb93dcc370fa74e2fc06aeceb6dda8276212826c.zip
x11-plugins/wmSun: add 1.06
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmSun/Manifest1
-rw-r--r--x11-plugins/wmSun/wmSun-1.06.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmSun/Manifest b/x11-plugins/wmSun/Manifest
index c0006533da1a..80c12831e959 100644
--- a/x11-plugins/wmSun/Manifest
+++ b/x11-plugins/wmSun/Manifest
@@ -1 +1,2 @@
DIST wmsun-1.05.tar.gz 20680 BLAKE2B 86e75467133b23e3f062203df6bbd8fe0aa1ca90c468bd91f3de3ec360e4d677bf5a117becf63e111557a17dbf346a1b23a61b78030d197264d71989097c9d77 SHA512 baa610db04ba67ca09112765e28c0fa945a98a61b642925dbaaa56a5b3e7da7424d8dd15097dcec932e3b603219d1f8806c0e50c025370226a157791f16911da
+DIST wmsun-1.06.tar.gz 20127 BLAKE2B 29321a11e652d90b62eea54c0db30154f65a1b7f9b9c1638784888fdf17205d4fb2976f39c47508b1822492ceea46fc12df5fc4739d5c1db5f6bdbc0f8018ab3 SHA512 475ebbce615b7b0ba24994654a8cd1e1429bda02d0b95522e8998c2be6ee11830c16be913e295cd77886fe51ac95801cc84c3ff4eb160c70d173e80e43af70ca
diff --git a/x11-plugins/wmSun/wmSun-1.06.ebuild b/x11-plugins/wmSun/wmSun-1.06.ebuild
new file mode 100644
index 000000000000..c101aec990ed
--- /dev/null
+++ b/x11-plugins/wmSun/wmSun-1.06.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+MY_P=${P/S/s}
+DESCRIPTION="dockapp which displays the rise/set time of the sun"
+HOMEPAGE="https://www.dockapps.net/wmsun"
+SRC_URI="https://www.dockapps.net/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( BUGS README TODO )
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ einstalldocs
+}