summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-09-22 15:32:58 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-09-22 16:06:20 -0400
commitbba2c91a04e8c3149195e333852b5e1325efeb05 (patch)
tree750d6b74f971fde1e599749e765ee098dc56d35b
parentdev-util/bpftrace: add 0.16.0 (bug #868519) (diff)
downloadgentoo-bba2c91a04e8c3149195e333852b5e1325efeb05.tar.gz
gentoo-bba2c91a04e8c3149195e333852b5e1325efeb05.tar.bz2
gentoo-bba2c91a04e8c3149195e333852b5e1325efeb05.zip
app-admin/djbdns-logparse: new package, add 0.0.1
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--app-admin/djbdns-logparse/Manifest1
-rw-r--r--app-admin/djbdns-logparse/djbdns-logparse-0.0.1.ebuild31
-rw-r--r--app-admin/djbdns-logparse/metadata.xml7
3 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/djbdns-logparse/Manifest b/app-admin/djbdns-logparse/Manifest
new file mode 100644
index 000000000000..debe5329f77f
--- /dev/null
+++ b/app-admin/djbdns-logparse/Manifest
@@ -0,0 +1 @@
+DIST djbdns-logparse-0.0.1.tar.gz 23317 BLAKE2B d44b2af042990dc1632746e111ecb53dcd16cd0a245a778f198163afb7de26a5f41cf624c81fe06dbffad94c9370e24267bb3c69176b4afb2e26a71fa5fa1afc SHA512 e066875d3718ab7780c6a82ed022106bd26b454827532beb2f6f2ef5e38d2619b71067250b9ed22eea03380da2f0e68b26931ceb99d9300e15be77d070d7fdf2
diff --git a/app-admin/djbdns-logparse/djbdns-logparse-0.0.1.ebuild b/app-admin/djbdns-logparse/djbdns-logparse-0.0.1.ebuild
new file mode 100644
index 000000000000..a37424d8def8
--- /dev/null
+++ b/app-admin/djbdns-logparse/djbdns-logparse-0.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Make tinydns and dnscache logs human-readable"
+HOMEPAGE="http://michael.orlitzky.com/code/djbdns-logparse.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# djbdns-logparse pipes the logs through the "tai64nlocal" program
+# that comes with sys-process/daemontools.
+RDEPEND="sys-process/daemontools"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_install_all() {
+ doman "doc/man1/${PN}.1"
+ local DOCS=( doc/README )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/app-admin/djbdns-logparse/metadata.xml b/app-admin/djbdns-logparse/metadata.xml
new file mode 100644
index 000000000000..c6418674131d
--- /dev/null
+++ b/app-admin/djbdns-logparse/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>