summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-03 10:02:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-03 10:26:12 +0200
commitbbaa255a45f5219e5f8e8e8d5a67544b73603238 (patch)
tree9040e7d84a875aa631e6a1f33823391cf7b66b39
parentdev-python/pylint: Bump to 2.13.8 (diff)
downloadgentoo-bbaa255a.tar.gz
gentoo-bbaa255a.tar.bz2
gentoo-bbaa255a.zip
dev-python/dask: Bump to 2022.05.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.05.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 3599401a35d1..ac8c8671e9c6 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -2,3 +2,4 @@ DIST dask-2022.03.0.gh.tar.gz 8192610 BLAKE2B 1099dac34487dc51b9010746920e64e4e7
DIST dask-2022.04.0.gh.tar.gz 8649475 BLAKE2B 92602e239be8c281ca450eb3fb1dbafea2f5caba12f83cd6d05670431b945dba861d92481f5ec1ec0834ccf35af6658d482b26d25cf16c8b784364adbe7e9ccf SHA512 2abc10a1140ad81a5f6bdc7ff697b899a5410da6dff976c98fb30d32fff625078ebf5ed23b2317c94d293973040b05bf650c02aef2b8c18230bf2841e54c71fa
DIST dask-2022.04.1.gh.tar.gz 8647138 BLAKE2B 7b53a033e2128d7a9ab738b88b3df4b80526e4a6a9b67e4347d318d137a3d4c9b5ae587b5f73b80c4f8186d98de0877827c6ee2b4c42536ac0bca369ed1b765b SHA512 356a94fad6cf9878b0c1e35b39e0db08a66c0d4c77cfae9fd7542a16b8f86b40475ff466e0dce7228e8930e6c03dc13c4f9df036b3a35806c2bc19525ab2e23f
DIST dask-2022.04.2.gh.tar.gz 8657501 BLAKE2B e0c78d91927d4f2391e377d10c93b87ebc8bed764be77e3e8afb55935819772442e9bd9eb6221b639eb8376de0107b361b43bd37ed85cbe548d4b0c99d5e5f68 SHA512 b252a19fb08e089153e31ea23bbb75d37cc9fbf96c530495e884b9e3768d23b7dfe71a16341a8c414c414298cc6958aa41f22af07cabb392816dc4590b86b278
+DIST dask-2022.05.0.gh.tar.gz 8658529 BLAKE2B 0b09ef38137d9c395384549fd8a3b0218ad1761ccb1816f8fc4f4af7328215716603e3f41b8cc3bf7044ff42b72eee277147b3bd03da48467cccc88f239bb2bd SHA512 15605321143f354ffb9c890823f5751131d942cc16c523b2d00bdcc752ddc5243525f7cda138091604c8f2f9c5b4a309b1efc95f483b753673df98cc8a81ce81
diff --git a/dev-python/dask/dask-2022.05.0.ebuild b/dev-python/dask/dask-2022.05.0.ebuild
new file mode 100644
index 000000000000..63da90a7d5d0
--- /dev/null
+++ b/dev-python/dask/dask-2022.05.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}