summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 18:58:47 +0000
committerSam James <sam@gentoo.org>2020-08-02 18:58:47 +0000
commitbbcb9693500c5ce7e59adb947aa096e296339361 (patch)
treed223505782d9a08852a82f8a3a62a43ee317b3e8
parentnet-mail/rss2email: 3.12.1 (diff)
downloadgentoo-bbcb9693.tar.gz
gentoo-bbcb9693.tar.bz2
gentoo-bbcb9693.zip
dev-python/theano: bump to 1.0.5
This adds support for Python 3.8+. We also drop pyflakes and exclude the single flakes8 test. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/theano/Manifest1
-rw-r--r--dev-python/theano/theano-1.0.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/theano/Manifest b/dev-python/theano/Manifest
index 56b8e6682d5b..dfa384a37398 100644
--- a/dev-python/theano/Manifest
+++ b/dev-python/theano/Manifest
@@ -1 +1,2 @@
DIST Theano-1.0.4.tar.gz 2840691 BLAKE2B 7f89caee3dd50d75ff09693fde7926f2b7da0f94758ef932f207feea29d74d38ed56591e6ebe0b46cfa043d5fb46d5b97028171acdfd324a01eb7b904169b4ac SHA512 3cc7f9dbb606c3c997c8651c34dd861721d5a8b99d06ed0887306d5a5ad0d7e402fbe29dcb5ad2f513b3bf75966e41a2854ebdf9a4fb212607345f84f367de8c
+DIST Theano-1.0.5.tar.gz 2842778 BLAKE2B ee82e9487a5265a1040750ace70465c450134e70eba4e58752cbaa7d487be5fb3cce31b838429cb52f7bc31d32a20379e158ee289dd5732dd8b86a9ee36b6d89 SHA512 6bb27753957d32392ea793e39ea56eff94baafbb55e27488f9c0bbdb387172a6829e64f461f83dae192486d9764b72d815e3b8dc059b2af116b024fc7228a118
diff --git a/dev-python/theano/theano-1.0.5.ebuild b/dev-python/theano/theano-1.0.5.ebuild
new file mode 100644
index 000000000000..9adbc14e3978
--- /dev/null
+++ b/dev-python/theano/theano-1.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 eutils
+
+MY_P=${P^}
+
+DESCRIPTION="Define and optimize multi-dimensional arrays mathematical expressions"
+HOMEPAGE="https://github.com/Theano/Theano"
+SRC_URI="mirror://pypi/${MY_P::1}/${MY_P%-*}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="test? ( dev-python/parameterized[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e "s/, 'flake8'//" setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ nosetests --verbosity=3 -e test_format_flake8 || die
+}
+
+pkg_postinst() {
+ optfeature "Make picture of Theano computation graph" dev-python/pydot-ng
+ optfeature "Required for GPU/CPU code generation" dev-python/pygpu
+}