summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-27 16:28:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-27 17:13:31 +0100
commitbbd34f942dbf42146a26a6e9d20f44abfd2156d7 (patch)
treed53d7e2c86c2fe975e568cbc852f35753c5b12a1
parentdev-libs/quazip: Drop old (diff)
downloadgentoo-bbd34f94.tar.gz
gentoo-bbd34f94.tar.bz2
gentoo-bbd34f94.zip
media-video/tsmuxer: Drop USE=qt4
Bug: https://bugs.gentoo.org/641956 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--media-video/tsmuxer/tsmuxer-2.6.11-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-video/tsmuxer/tsmuxer-2.6.11-r1.ebuild b/media-video/tsmuxer/tsmuxer-2.6.11-r1.ebuild
new file mode 100644
index 000000000000..ea8db60637db
--- /dev/null
+++ b/media-video/tsmuxer/tsmuxer-2.6.11-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Utility to create and demux TS and M2TS files"
+HOMEPAGE="http://forum.doom9.org/showthread.php?t=168539"
+SRC_URI="https://drive.google.com/uc?export=download&id=0B0VmPcEZTp8NekJxLUVJRWMwejQ -> ${P}.tar.gz"
+
+LICENSE="SmartLabs"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+QA_FLAGS_IGNORED="opt/${PN}/bin/tsMuxeR opt/${PN}/bin/tsMuxerGUI"
+
+DEPEND="|| (
+ >=app-arch/upx-ucl-3.01[lzma]
+ >=app-arch/upx-bin-3.01
+)"
+RDEPEND="
+ >=media-libs/freetype-2.5.0.1:2[abi_x86_32(-)]
+"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ upx -d tsMuxeR tsMuxerGUI || die
+}
+
+src_install() {
+ dodir /opt/bin
+ exeinto /opt/${PN}/bin
+
+ doexe tsMuxeR
+ dosym ../${PN}/bin/tsMuxeR /opt/bin/tsMuxeR
+}