summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-02 18:53:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-02 19:37:43 +0200
commitbbd83c466ca377a596b0233a3be47382294af66e (patch)
tree6f2093180799caf3d64fa4e35630c57e1244eef4
parentdev-python/json5: Bump to 0.9.10 (diff)
downloadgentoo-bbd83c46.tar.gz
gentoo-bbd83c46.tar.bz2
gentoo-bbd83c46.zip
dev-python/shapely: Bump to 1.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/shapely/Manifest1
-rw-r--r--dev-python/shapely/shapely-1.8.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index e0d2a0642263..6f075ebea7f1 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1 +1,2 @@
DIST shapely-1.8.2.gh.tar.gz 322064 BLAKE2B f21f91eb58818aa30464c719b1079d382c5a00f13eda70c532e4a12f1612284240e5c8c110a867c74eaa4aac5f3a21fd10b23c7ce781808d4adc871d038b8b2b SHA512 c85323f180622235257aed28c85640c63bb43cbcb2bd7ed9b354a0f23a92e0ca8becf7a94e85edea3a90cfd01017ddfc6f268f4bb2945639c2cae29a73292bd6
+DIST shapely-1.8.4.gh.tar.gz 322701 BLAKE2B 79cca2290b8e32ac146316feff4ccb332d47dd11ec4753f83618305c169e085629858c5e9d66fe281adda36be46eaebe996e2fe67dace1e6cbe9a7ca322c1c18 SHA512 8b57a2e83f8eb10a041f6a8d9170b84ed708a5835a16874761e5ccec0453ff34a282aeefb0367ab79c85216a68f5bb8b4b75503e81eaa3f7277f4036b8b0b242
diff --git a/dev-python/shapely/shapely-1.8.4.ebuild b/dev-python/shapely/shapely-1.8.4.ebuild
new file mode 100644
index 000000000000..e123057db79a
--- /dev/null
+++ b/dev-python/shapely/shapely-1.8.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/Shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/matplotlib
+
+src_prepare() {
+ rm -r _vendor || die
+ sed -i -e 's:_vendor\.::' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf shapely || die
+ epytest
+}