summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-09-04 14:03:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-09-04 14:07:21 -0500
commitbbe80134d999d51ce93db076dfe12ac9290b4fc6 (patch)
treea1134193edd18ee8754628cec4eaf667a4b86e50
parentapp-crypt/certbot: 0.38.0 bump (diff)
downloadgentoo-bbe80134.tar.gz
gentoo-bbe80134.tar.bz2
gentoo-bbe80134.zip
app-crypt/certbot-apache: 0.38.0 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.38.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index dea77f04e8ee..dab4179b69d6 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,2 +1,3 @@
DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
DIST certbot-0.37.2.tar.gz 1327361 BLAKE2B 2f36276f527ffc29e54cf58f25051952e9435972a94881e420712844401fc86b2a0220d651f56c07fbff69e12114fdb1d3c0650fc5fc6a4539ff1c279a0b4c24 SHA512 2e357dfcb6da669f1ab6e4f9aa3e8e3457ce0f794f40c9ac862a9f24208b4f4d773dbafffd97fd1f7e5b2a29e1ca99be787101469384a9e61b4ddb077b644211
+DIST certbot-0.38.0.tar.gz 1328474 BLAKE2B 6ea7c6b5d1840ec9d42509859d0f36f3ac3c4e588149e54fd74f8799a414b43c4d182b47e051a96436c9cdac135999d7e2a25424be680a819d50de64bb85b198 SHA512 832ac36c5b13e9764c9aab40856af7b909b630f34b1fe1e42dbf847357b28b2a130df480f1cb543dad0db781a843a79a310eba7b1097370e267d01431c21ee29
diff --git a/app-crypt/certbot-apache/certbot-apache-0.38.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.38.0.ebuild
new file mode 100644
index 000000000000..5ac928afccf9
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.38.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-0.36.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}