summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 09:25:57 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 09:34:47 +0100
commitbbf79278af4bdd0b23597f95a59b0c232905c82c (patch)
treef71e215f51099b2f38a47640be63e99102ddff0e
parentdev-python/xlrd: EAPI 8, PEP517 (diff)
downloadgentoo-bbf79278.tar.gz
gentoo-bbf79278.tar.bz2
gentoo-bbf79278.zip
dev-python/xlwt: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xlwt/xlwt-1.3.0-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/xlwt/xlwt-1.3.0-r2.ebuild b/dev-python/xlwt/xlwt-1.3.0-r2.ebuild
new file mode 100644
index 000000000000..42a90bd7410c
--- /dev/null
+++ b/dev-python/xlwt/xlwt-1.3.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
+HOMEPAGE="https://pypi.org/project/xlwt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ dev-python/pkginfo
+distutils_enable_tests nose
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+ distutils-r1_python_install_all
+}