summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 19:44:18 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:00:34 +0300
commitbc0351282bba587d90b8fe5811033aceef4ef502 (patch)
tree1f9ccf808775c43bb4dc21076acec84e5fa01da4
parentlxqt-base/lxqt-notificationd: add version 0.17.0 (diff)
downloadgentoo-bc0351282bba587d90b8fe5811033aceef4ef502.tar.gz
gentoo-bc0351282bba587d90b8fe5811033aceef4ef502.tar.bz2
gentoo-bc0351282bba587d90b8fe5811033aceef4ef502.zip
lxqt-base/lxqt-policykit: add version 0.17.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--lxqt-base/lxqt-policykit/Manifest1
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-0.17.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/Manifest b/lxqt-base/lxqt-policykit/Manifest
index faf5cadef81a..a4652047369a 100644
--- a/lxqt-base/lxqt-policykit/Manifest
+++ b/lxqt-base/lxqt-policykit/Manifest
@@ -1 +1,2 @@
DIST lxqt-policykit-0.16.0.tar.xz 38016 BLAKE2B dd077f1a25b9bb5ee56f7ad08f24254936f3b5f1b6ab4c9148ebce160867b8535341353339470d4363fbb52eead522133ed702f7d98b78cc08df58eeb5d6467b SHA512 f6eae925cbf25064addf5d89999d16a7397ddb0d8c616f75a3b81df57a42a70e52da599fdad6b8589a1e951cf46cd541e9a23e352a0d2ee309116b6e0238cfa9
+DIST lxqt-policykit-0.17.0.tar.xz 38272 BLAKE2B e141d0ff7a583b22ddddcde3875cf82a5215cef0c6270774b3b31e21608f16bc78dd45b3b36b8ba1fde3bbeda30b2f638a47ecf7dee1797da151cb701fecc866 SHA512 1cfd4b2d21840704e4b15ae71098e9c6f3d51031293f1fdf6e134ffee867fe4e845caaf24fbd2c107317372b90b6d415a76854977fa8f6b703e708bd09120328
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-0.17.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-0.17.0.ebuild
new file mode 100644
index 000000000000..58cf474ee82f
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-0.17.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-auth/polkit-qt[qt5(+)]
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}