summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-12-19 03:37:25 +0200
committerMart Raudsepp <leio@gentoo.org>2017-12-19 03:54:48 +0200
commitbc09f4fed846448829bdbab0f55a430e121ecfee (patch)
treed0bc39dcd0c55cc7a25024f202d7b178751e1669
parentdev-libs/appstream-glib: remove old (diff)
downloadgentoo-bc09f4fed846448829bdbab0f55a430e121ecfee.tar.gz
gentoo-bc09f4fed846448829bdbab0f55a430e121ecfee.tar.bz2
gentoo-bc09f4fed846448829bdbab0f55a430e121ecfee.zip
dev-libs/libinput: bump to 1.9.4
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.9.4.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 8441f0c4f8f4..b2366ba051ed 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -3,3 +3,4 @@ DIST libinput-1.7.3.tar.xz 922464 BLAKE2B fa38675905af55931676c22d9e4d56befbb055
DIST libinput-1.8.3.tar.xz 941832 BLAKE2B cf6464d68387cca23d0f70eaceeec8b453c53f1cac22892722d48983788b43a136617c62ad39c8d435bbf07c0cb9cd720250ea91e31f10526acd5147b1d78237 SHA512 88006d217e3507858fa6b9ac1f25c267255fb51d1bcf1208d2afd423bf2a9292944bc5526ea91f27fad3ff04c2f9f43ab3aa25fd9fb7ace1231ecd33ddf18de6
DIST libinput-1.9.2.tar.xz 460388 BLAKE2B 227f24ef299861d043df1da58e6fea9c419a5583abe2ae526a59f248536668f25702d0fca07719dd2b407bb42c27722ce5439bcb75c559abcf2c1b3c3c6edbb7 SHA512 99719ab26be8ed35937ce91307459fa8c4aa7c383a555f1012a058ba98ca1d1c5df0d9b5e6a45046341c6dbae496dc29512b487ac7873b6ec67cab1176ee04ac
DIST libinput-1.9.3.tar.xz 473724 BLAKE2B 2cad3514f2e04505f015a8d105eaecb9ffb93ce57ccc2b035e5e031f72d278d966bae16fd804e7f315d0d651021567b2118fc9e53ee64d91e6e34cec6b92a8cf SHA512 33fb17724d4c2992bf31f9bb2e0825955468058e122ad420678b01ee293e1651d659fbae8873a7913f571243b3618032774cd350d2513eb73320d40aaa9953d1
+DIST libinput-1.9.4.tar.xz 472636 BLAKE2B 692a23047cb0b54d14763b34ce3ce1414101d0097dce10d237ec32a67f29c31cbf2928681084f7561e072e555c932f0e3bc54cfb0ecbcdd0d823426806e357b6 SHA512 302f9497ea9ffb2163c643e9ca2f0a773ea141f6fe0a3aa3d8e86eb11a5d11e75d858b1e679ebfd3f913c645beac059cfd356b37c4ea17a8853068f79a740a4b
diff --git a/dev-libs/libinput/libinput-1.9.4.ebuild b/dev-libs/libinput/libinput-1.9.4.ebuild
new file mode 100644
index 000000000000..89bf24d7c505
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.9.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit meson udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ -Ddocumentation="$(usex doc true false)"
+ -Dlibwacom="$(usex input_devices_wacom true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/html/.
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}