summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-04-01 22:25:20 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-04-01 22:25:20 +0600
commitbc1cef9f99c07c68ed0203336bd15eae94536d77 (patch)
tree728d9d77300a4015c581346b4878dd3415667ecb
parentdev-python/prompt_toolkit: bump to 0.60 (diff)
downloadgentoo-bc1cef9f.tar.gz
gentoo-bc1cef9f.tar.bz2
gentoo-bc1cef9f.zip
dev-python/docopt: added python3_5
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/docopt/docopt-0.6.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/docopt/docopt-0.6.2-r1.ebuild b/dev-python/docopt/docopt-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..8161713e3207
--- /dev/null
+++ b/dev-python/docopt/docopt-0.6.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic argument parser, that will make you smile"
+HOMEPAGE="https://pypi.python.org/pypi/docopt https://github.com/docopt/docopt"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/docopt/docopt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# not implemented in this version, git already has it
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}