summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-05-03 06:46:31 -0500
committerBen Kohler <bkohler@gentoo.org>2022-05-03 06:48:33 -0500
commitbc2aec96cf0613f0dbf0ab56299ad9ad1f9562a7 (patch)
tree1e45884de467077da44263d0f42741a1213ca732
parentdev-python/matplotlib: Remove obsolete test removal (diff)
downloadgentoo-bc2aec96.tar.gz
gentoo-bc2aec96.tar.bz2
gentoo-bc2aec96.zip
media-gfx/fotoxx: add 22.16
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-22.16.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index 748719af5b9b..5b870c150868 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -1,3 +1,4 @@
DIST fotoxx-21.60.tar.gz 8679841 BLAKE2B ec3dcbd0b937d730692e225fec7530ac46390328ae960e8960df7d252bc0cd8630de84bf47dfaf74c1e07855b4b0959e596e5e515ea00a6c430872359b2b4576 SHA512 ac999fcc70acd92c54e85ad276112aaa7f1b7606ea70381d6f833d829fd92c14aacad7a967838e5d28fce80cfa6da8ef05e0ee49b463210cb66a3f8ffc3d22e7
DIST fotoxx-22.14.tar.gz 8815290 BLAKE2B fa6399454edebbbff6504fc9e7f8b27fbfecea0083a309cfeefd8d0f4834693a1c7eab8a689cb1a2135293e1290650cb44412375d20fe808014c5a5213c979d5 SHA512 7a0e412131a286ebc0ce8f5d7589ec135909a9d74e5a0f4a5367e58484462c23948c2b0ccc10c5197ba1014013f2d31999dd63d460daa4c4d4aa194313ee3c7b
DIST fotoxx-22.15.tar.gz 8948263 BLAKE2B 99b4e6891751de62b880de6c51ee3ce2720f773ae03fad5d3b4c433e20cfb288efab9c5074841ba9c535374d3a9b860131c303f6539e889d7f747380d1c9f1db SHA512 4f317a34a72db2e6289e17c9d2d036150e0e633ac84a0bcd0dd8b00367a3c31ea6172b7cceab0f358c0db46057d9e0331e0f0a304ebe86b9a1b717f6fa4f54fd
+DIST fotoxx-22.16.tar.gz 8984376 BLAKE2B 4a5665313133405b4a53d7e40986e37601b5c9552f20c07d5f0889f3dacbabce1b4a712fcb216fe3358e7ad1de12da608961a996b081e4b3d644c5581ebcc6ee SHA512 ff78b0d7bbde0de5d98ac42d63c36f4bdcd425ae210dfcda6f64f4307be02dfca2966475df3f962751f73afc8e9442d2eb975725db31745109e174fe1665f804
diff --git a/media-gfx/fotoxx/fotoxx-22.16.ebuild b/media-gfx/fotoxx/fotoxx-22.16.ebuild
new file mode 100644
index 000000000000..6444b3fb63f4
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-22.16.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0
+ media-libs/tiff:0
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-21.40-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}