summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-08 07:51:50 +0000
committerSam James <sam@gentoo.org>2021-06-08 07:51:50 +0000
commitbc42a3e1c3bd8b861936c63593fbbd525856a877 (patch)
treebfe12470e128c378e222a7e32561ffbdd407f5a1
parentdev-python/pybind11: Keyword 2.6.2 sparc, #760803 (diff)
downloadgentoo-bc42a3e1c3bd8b861936c63593fbbd525856a877.tar.gz
gentoo-bc42a3e1c3bd8b861936c63593fbbd525856a877.tar.bz2
gentoo-bc42a3e1c3bd8b861936c63593fbbd525856a877.zip
sci-libs/scotch: fix toolchain sed for e.g. arm
Closes: https://bugs.gentoo.org/577272 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/scotch/scotch-6.0.4-r2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-libs/scotch/scotch-6.0.4-r2.ebuild b/sci-libs/scotch/scotch-6.0.4-r2.ebuild
index 8af0ccfe611a..4a01b91e5ca2 100644
--- a/sci-libs/scotch/scotch-6.0.4-r2.ebuild
+++ b/sci-libs/scotch/scotch-6.0.4-r2.ebuild
@@ -64,10 +64,12 @@ src_prepare() {
-e 's/ -DSCOTCH_PTHREAD//' \
src/Make.inc/Makefile.inc.i686_pc_linux3 || die
fi
- sed -e "s/gcc/$(tc-getCC)/" \
+
+ # Be careful with replacing here, bug #577272
+ sed -e "s/= gcc$/= $(tc-getCC)/" \
-e "s/-O3/${CFLAGS} -pthread/" \
- -e "s/ ar/ $(tc-getAR)/" \
- -e "s/ranlib/$(tc-getRANLIB)/" \
+ -e "s/= ar$/= $(tc-getAR)/" \
+ -e "s/= ranlib$/= $(tc-getRANLIB)/" \
-e "s/LDFLAGS/LIBS/" \
src/Make.inc/Makefile.inc.i686_pc_linux3 > src/Makefile.inc || die
}