summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-09 00:43:10 +0000
committerSam James <sam@gentoo.org>2022-03-09 01:09:02 +0000
commitbc488f82c9e5853bd6b3e1509f7ae19d57e18bac (patch)
tree52cbdae7cd316399a6dff25610ed4ad1b1f1050e
parentsci-mathematics/mathlib-tools: add python3.10 compat (diff)
downloadgentoo-bc488f82c9e5853bd6b3e1509f7ae19d57e18bac.tar.gz
gentoo-bc488f82c9e5853bd6b3e1509f7ae19d57e18bac.tar.bz2
gentoo-bc488f82c9e5853bd6b3e1509f7ae19d57e18bac.zip
dev-cpp/pangomm: add 2.48.2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-cpp/pangomm/Manifest1
-rw-r--r--dev-cpp/pangomm/pangomm-2.48.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/Manifest b/dev-cpp/pangomm/Manifest
index 06c798d3e1b3..d30e5f61d51d 100644
--- a/dev-cpp/pangomm/Manifest
+++ b/dev-cpp/pangomm/Manifest
@@ -1,4 +1,5 @@
DIST pangomm-2.42.2.tar.xz 656760 BLAKE2B 8fae779aa78b2337b83759adc7aadec1f61c08c54d892e3cdd05180e2ab032a61faa72c39281fab649bcd08591c5d7ace9ea65b25f76ce17d6f4d96f38900b6a SHA512 5e4826d64c0178527b4df73e901d2fdf5661d41777e189f5e2d4b26577e42689efaccf5a28502246c6b3926571ccd5876cb23d33267b44ace7ee164322c14667
DIST pangomm-2.46.2.tar.xz 674892 BLAKE2B ac86ef1a229dca29eeb41d3751128bed56d182cecfc6655a478b5a7473d10782fe98cdfee4db6f5afbfe9fb8adbf0e646004aa69c4c4058191078c7b5716434b SHA512 79cad137ec9f22e57a177332df6c6e735aa3baf81df36fc706e81e7a89f23ce3179337507388f65a0d0a74733990dc3547c50243a4559dfd0bb065b1828c0474
DIST pangomm-2.48.1.tar.xz 675452 BLAKE2B bb012fc5cb66d5cb98f522e3706fdd35bcc5692fcd942f86ee1e20116590ceca26874c5a58bd3f8fac4f154700dfb37ea060747a6c3069e67adf83ba551e7abc SHA512 c204a1cb7a404f055d62880a760716c5567a835ca495cc5e01589ed59fabb332490e529de716c3438cefbc4428c025d6d01c71e4412b2843e3ab3a3175ccc2f4
+DIST pangomm-2.48.2.tar.xz 696364 BLAKE2B c4a9b99ec2b05c0b7a83dd6007318f53952f51b3c8b4b558e738fd2e054625f8cc00cf51eb4950796f647cbe4b8ea701b232f429180cdc8aad1faca11a580fc6 SHA512 631529f27aaf8aa69344f5c4c30921c88e947f9f1ec828d591a9a31c497ab0e52ef1ddd19064d305858c15f807e14f315eafec5a1b755f9561153d5275cdf66e
DIST pangomm-2.50.0.tar.xz 753592 BLAKE2B 0db7d43fe2d23e4cfc2b083a4d832c7875c63a261c6b10c62898bf428351ea7d8d05136a46f9498cdb78c51a0223ca988cbc3481041b997dc5d6a9f16f02ec91 SHA512 844850db93b8c4dab19dd364e674ee3d61b2fcb8e020ab3d314f240065ee17aeceea21e9ddc438a7d09d56410e3f82147a57425f76bb01e26d82872934269477
diff --git a/dev-cpp/pangomm/pangomm-2.48.2.ebuild b/dev-cpp/pangomm/pangomm-2.48.2.ebuild
new file mode 100644
index 000000000000..3d5fe359c4ef
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.48.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.48"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/cairomm-1.16.0:1.16[doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.68.0:2.68[doc?,${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-3:3[doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.48.0[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dmaintainer-mode=false
+ $(meson_native_use_bool doc build-documentation)
+ )
+ meson_src_configure
+}