summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-04 05:18:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-04 05:59:57 +0200
commitbc979b454c12239f2cd1a532cbaccf7cabcb827e (patch)
tree91eee49536e0a53d2e535f97476bd97ecc51afb7
parentdev-python/tifffile: Remove old (diff)
downloadgentoo-bc979b454c12239f2cd1a532cbaccf7cabcb827e.tar.gz
gentoo-bc979b454c12239f2cd1a532cbaccf7cabcb827e.tar.bz2
gentoo-bc979b454c12239f2cd1a532cbaccf7cabcb827e.zip
dev-python/tifffile: Bump to 2024.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2024.5.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 9c7691e19d64..6a3c8de8c372 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1 +1,2 @@
DIST tifffile-2024.4.24.gh.tar.gz 346320 BLAKE2B 55f755044a6ee3826beaa8c9d39e5351474d73a64bd2af7d7e31dc20ac156c762b93a5d4986cd3dab8a70ed3b1674fe47e7ed07834a8833dcfa15fe6f179ccb5 SHA512 7ca3b32596210878e24c48475df8b95b193906669f0c561ba0567b6159fe951dd0d89ab83b094ba859da526e6c456d21e4b53bcc6038824556a0391d48a601f5
+DIST tifffile-2024.5.3.gh.tar.gz 347188 BLAKE2B 965b216c69f3257870298303ed165e6c5a9a581c079ec349156e40e8d812dd21cf2b8f7b2d3036ae4f2357296e6c6035ac52d8b7e799dd57b0c63287415c1a70 SHA512 46d90a78c0cf8111fd7c9a22ead8f4b8e1715a57cb0e7be0112027e44495d8d239ebe87433e94865b0925e47eb43af13b720318e906c63c0848c52e4f17f22d7
diff --git a/dev-python/tifffile/tifffile-2024.5.3.ebuild b/dev-python/tifffile/tifffile-2024.5.3.ebuild
new file mode 100644
index 000000000000..190a5b9ccada
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.5.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}