summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-04 08:04:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-04 09:00:19 +0200
commitbc9a72875444097fb0032c707a4dc1d57f754df5 (patch)
tree36d0d8050818e48bf9932d39def750abf1bf8a5e
parentdev-python/pyghmi: Bump to 1.5.44 (diff)
downloadgentoo-bc9a7287.tar.gz
gentoo-bc9a7287.tar.bz2
gentoo-bc9a7287.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.18.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.18.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index adacc2ddfbf4..0268e06a7b06 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1 +1,2 @@
DIST sphinx-autodoc-typehints-1.18.1.gh.tar.gz 26424 BLAKE2B a30b966d26e89a7771404d4f9434038e4f201458bda439bf8fb3d2c2fc6dac0f12743622193edf45335d04148c96b6c3d51c2c7fe5437cb67b3b272ab19b2f18 SHA512 6c788949d1d3903ac589283e9188d5db3e0f173be1bb1a4740a88fc0383d7011fe60e57d25af74a2fc147b3c4d76c48770515bb8dbdf4ff18fb4bfb110a4a241
+DIST sphinx-autodoc-typehints-1.18.2.gh.tar.gz 26466 BLAKE2B d2e6e3135c5a60966338b2c8b143cab7c2a1b788abde0deb9cf3dc989ad31a1680ff07a9e3cb9bad500d053e7f0af2b5e099331bd92a2e01911333c6eb1589bf SHA512 5828cce6744a6a55e5dd25dc15b5bb6b28fcf430c5b65f8d610e24da426efe020e72af73ffee1f7929b3007fc76afc64f70c65d1f7e8db62b86ce52e2f836487
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.18.2.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.18.2.ebuild
new file mode 100644
index 000000000000..9eca6f1f4db5
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.18.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-4.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.1.1[${PYTHON_USEDEP}]
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}