summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-09-13 15:42:33 -0400
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-18 21:53:04 +0300
commitbcb08397d3573114ebf95778a5ec212ced44867d (patch)
treeaabe844cbaad50ec907954c0da2482eb9332e730
parentapp-text/sigil: unconditionally require dulwich dependency (diff)
downloadgentoo-bcb08397.tar.gz
gentoo-bcb08397.tar.bz2
gentoo-bcb08397.zip
app-text/sigil: move required python USE on tk, to plugins support
sigil does not use the python tkinter module itself. Like all packages pulled in by USE=plugins, tkinter is solely used by thirdparty plugins and only listed in the sigil documentation under: > but if you want to make use of Sigil plugins that people are > developing, you will also want to install the "standard" modules that > ship with the binary version of Sigil on Windows and OS X. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-text/sigil/sigil-1.9.30-r1.ebuild4
-rw-r--r--app-text/sigil/sigil-2.0.1-r2.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-text/sigil/sigil-1.9.30-r1.ebuild b/app-text/sigil/sigil-1.9.30-r1.ebuild
index 0f6c57540d76..7b6edc8d402c 100644
--- a/app-text/sigil/sigil-1.9.30-r1.ebuild
+++ b/app-text/sigil/sigil-1.9.30-r1.ebuild
@@ -4,7 +4,6 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="tk"
inherit xdg cmake python-single-r1
@@ -40,7 +39,8 @@ RDEPEND="
dev-python/cssselect[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]') )
+ dev-python/regex[${PYTHON_USEDEP}]')
+ $(python_gen_impl_dep 'tk') )
"
DEPEND="${RDEPEND}"
BDEPEND="
diff --git a/app-text/sigil/sigil-2.0.1-r2.ebuild b/app-text/sigil/sigil-2.0.1-r2.ebuild
index b379019f0e7d..8e02edb86472 100644
--- a/app-text/sigil/sigil-2.0.1-r2.ebuild
+++ b/app-text/sigil/sigil-2.0.1-r2.ebuild
@@ -4,7 +4,6 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="tk"
inherit xdg cmake python-single-r1
@@ -39,7 +38,8 @@ RDEPEND="
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/regex[${PYTHON_USEDEP}]
- ') )
+ ')
+ $(python_gen_impl_dep 'tk') )
!qt6? (
dev-qt/qtconcurrent:5
dev-qt/qtcore:5