summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-01-26 18:30:28 -0500
committerMike Gilbert <floppym@gentoo.org>2020-01-26 18:33:03 -0500
commitbcb11aec5a7c5d40753e40482dc4cd12cf247bec (patch)
treeb3acbb8200d4bf7036b72bee561028ecca52f48e
parentapp-text/editorconfig-core-c: Add missing slash to fix CI (diff)
downloadgentoo-bcb11aec5a7c5d40753e40482dc4cd12cf247bec.tar.gz
gentoo-bcb11aec5a7c5d40753e40482dc4cd12cf247bec.tar.bz2
gentoo-bcb11aec5a7c5d40753e40482dc4cd12cf247bec.zip
sys-apps/gentoo-functions: bump to 0.13
Package-Manager: Portage-2.3.85_p2, Repoman-2.3.20_p36 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-apps/gentoo-functions/Manifest1
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.13.ebuild28
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild20
3 files changed, 38 insertions, 11 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index 34ce1ac1e416..9d74eed56863 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -1 +1,2 @@
DIST gentoo-functions-0.12.tar.gz 11514 BLAKE2B 88f626a977b6f7b7cde2df452b91ef9570d29f3e6488d23859077b4d31a441dd0eb9cc473263e06a67dd90b714e24cbcfc09d4c4003f9cd29c8b7aeb0f3c91f9 SHA512 181e09216e1ed78f590e0bb50c60cfb0295bfeef335ed6c957ea7f2a1d6145d91c0a6dc4377bd6cd538fb4e5871e9a5ef8332d91bc91931792d5f05f62bc4705
+DIST gentoo-functions-0.13.tar.gz 11334 BLAKE2B 740e6d950b62b777e533d16b707cbf6f9ab0e9de4c92c5e755af186571539949017aadcd7d428b1e635f43052a575f89787b3e92087675b600a6b7350fda24a6 SHA512 61185197e1eb4155d0db9ba024dcb1b9eb0d272e3369f986668634012e35b57c3cdcd7beecd4714b9b48a0e44e8bb73472713949e16827aa05c055ec83d537dd
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.13.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.13.ebuild
new file mode 100644
index 000000000000..3c1089a7586b
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_configure() {
+ tc-export CC
+ append-lfs-flags
+ export ROOTPREFIX="${EPREFIX}"
+ export PREFIX="${EPREFIX}/usr"
+}
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index a8780922f9d2..3c1089a7586b 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -1,30 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/gentoo/${PN}.git"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
else
- SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
fi
inherit toolchain-funcs flag-o-matic
DESCRIPTION="base functions required by all Gentoo systems"
-HOMEPAGE="https://www.gentoo.org"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
LICENSE="GPL-2"
SLOT="0"
IUSE=""
-src_prepare() {
+src_configure() {
tc-export CC
append-lfs-flags
-}
-
-src_install() {
- emake install DESTDIR="${ED}"
+ export ROOTPREFIX="${EPREFIX}"
+ export PREFIX="${EPREFIX}/usr"
}