summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-29 23:13:16 +0100
committerSam James <sam@gentoo.org>2021-10-29 23:22:37 +0100
commitbcb60bc5545947901192e23c9d404e8809b4d60c (patch)
tree5c69fe26f16bd5836f8af5848caa9de4d027510b
parentmedia-gfx/openvdb: add tbb subslot operator (diff)
downloadgentoo-bcb60bc5.tar.gz
gentoo-bcb60bc5.tar.bz2
gentoo-bcb60bc5.zip
sys-cluster/hpx: add tbb subslot operator
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/hpx/hpx-1.7.1-r1.ebuild (renamed from sys-cluster/hpx/hpx-1.7.1.ebuild)8
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/sys-cluster/hpx/hpx-1.7.1.ebuild b/sys-cluster/hpx/hpx-1.7.1-r1.ebuild
index 15cacad6996f..c1be762e1c26 100644
--- a/sys-cluster/hpx/hpx-1.7.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.7.1-r1.ebuild
@@ -35,13 +35,13 @@ RDEPEND="
${PYTHON_DEPS}
>=dev-cpp/asio-1.12.0
dev-libs/boost:=
- sys-apps/hwloc
+ sys-apps/hwloc:=
sys-libs/zlib
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
mpi? ( virtual/mpi )
papi? ( dev-libs/papi )
- perftools? ( dev-util/google-perftools )
- tbb? ( dev-cpp/tbb )
+ perftools? ( dev-util/google-perftools:= )
+ tbb? ( dev-cpp/tbb:= )
"
DEPEND="${RDEPEND}"
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 0c573198a762..e9869e80d74e 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -35,13 +35,13 @@ RDEPEND="
${PYTHON_DEPS}
>=dev-cpp/asio-1.12.0
dev-libs/boost:=
- sys-apps/hwloc
+ sys-apps/hwloc:=
sys-libs/zlib
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
mpi? ( virtual/mpi )
papi? ( dev-libs/papi )
- perftools? ( dev-util/google-perftools )
- tbb? ( dev-cpp/tbb )
+ perftools? ( dev-util/google-perftools:= )
+ tbb? ( dev-cpp/tbb:= )
"
DEPEND="${RDEPEND}"