summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-02 16:52:36 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-02 16:56:32 +0100
commitbcbccb297028d66eafc39a8bb6c0f9e1d6931083 (patch)
tree6304806ca24586024621d034d4c5fcf7d50e8918
parentx11-misc/xclip: Add live ebuild (diff)
downloadgentoo-bcbccb29.tar.gz
gentoo-bcbccb29.tar.bz2
gentoo-bcbccb29.zip
x11-misc/wbarconf: Fix docdir
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--x11-misc/wbarconf/wbarconf-0.7.2.2-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/wbarconf/wbarconf-0.7.2.2-r3.ebuild b/x11-misc/wbarconf/wbarconf-0.7.2.2-r3.ebuild
new file mode 100644
index 000000000000..2c5f19167c25
--- /dev/null
+++ b/x11-misc/wbarconf/wbarconf-0.7.2.2-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Configuration GUI for x11-misc/wbar"
+HOMEPAGE="http://koti.kapsi.fi/ighea/wbarconf/"
+SRC_URI="http://koti.kapsi.fi/ighea/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=x11-misc/wbar-1.3.3
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-install.patch
+)
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ python_fix_shebang wbarconf
+}
+
+src_install() {
+ ./install.sh "${ED%/}/usr" || die "./install.sh failed"
+ if [[ "${P}" != "${PF}" ]]; then
+ mv "${ED}"/usr/share/doc/{${P},${PF}} || die
+ fi
+}