summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-01 08:37:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-01 09:45:00 +0200
commitbcd5c2533a22a16ed948ba645d1891a0334f5331 (patch)
treebe008ed6359fa477ce4bb9627e9b73d66284d1f0
parentdev-python/pip: Bump to 21.1.1 (diff)
downloadgentoo-bcd5c253.tar.gz
gentoo-bcd5c253.tar.bz2
gentoo-bcd5c253.zip
dev-python/slixmpp: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/slixmpp-1.7.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index 782ce40d3790..d99bb3e3e83b 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1 +1,2 @@
DIST slixmpp-1.7.0.tar.gz 931610 BLAKE2B bb84e33681cc2701dbfc164ad4e727236dbe5fe1206a4c4e93843f9cbd870b6b3efb03b89ae61ddde4249c4928a81edaea9caf1d04b88e3b5cb0e81b1fe3fad7 SHA512 1f70f6b0419877865b80213a50ba181639cbf64fd808695d7a95eae460635a537492f72bed0e6d77d33dc9a5da4ec505da4cd44526bdee2a39b56b98a9974cfc
+DIST slixmpp-1.7.1.tar.gz 931753 BLAKE2B 3de14be36353bc5f5f2cfbe002c44c5e843a7b36fa31a9dd315e363fc67e36d080df0dc70d82e65c6802c41377c2e98f56ff4e23cc5e9a92165c3d3b7565493f SHA512 5a59fcbb901e6f4456049f1ec2bbf781b1ec7c5a3ad4b66216d4c5daffa7f0606f74b941647fe2b53e6c8cdc476371305c7b7a2ca24d21450e19548f888be3b1
diff --git a/dev-python/slixmpp/slixmpp-1.7.1.ebuild b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
new file mode 100644
index 000000000000..0f5e88aa5f6c
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ net-dns/libidn
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
+}