summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Jelten <jj@sft.mx>2019-01-27 00:08:01 +0100
committerVirgil Dupras <vdupras@gentoo.org>2019-01-31 20:10:11 -0500
commitbcd7942f7417ad0ad3bebd695bf8d7eb86f0fb51 (patch)
treea373041fbe9b8de83ab92082a22c3fdc98eb651d
parentdev-vcs/python-gitlab: python command line interface to the gitlab API (diff)
downloadgentoo-bcd7942f.tar.gz
gentoo-bcd7942f.tar.bz2
gentoo-bcd7942f.zip
dev-python/typed-ast: bump to version 1.2.0
Signed-off-by: Jonas Jelten <jj@sft.mx> Closes: https://github.com/gentoo/gentoo/pull/10907 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
-rw-r--r--dev-python/typed-ast/Manifest1
-rw-r--r--dev-python/typed-ast/typed-ast-1.2.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/typed-ast/Manifest b/dev-python/typed-ast/Manifest
index 62ddfe121bb6..e38af26501d5 100644
--- a/dev-python/typed-ast/Manifest
+++ b/dev-python/typed-ast/Manifest
@@ -1 +1,2 @@
DIST typed-ast-1.1.0.tar.gz 200587 BLAKE2B 09dd6d65513a37a57ecb6df2a505100f5fc08a49a244f1cb83af363d20d9b1b76f127ec5da6ef115a56ae6dc560ab40dcaae4740385fdd9e305bfd2ec26fdbaf SHA512 439e949082ee5cb9434fec99021c08401a46ec2ad16d96296c6440aa1fd8158f6605efbdfa55e536c3fddd4018bb0f4c5ee4d5a4a32954242b7902b9ce3463f2
+DIST typed-ast-1.2.0.tar.gz 202702 BLAKE2B 79e919019763f4af0a2f24108cfa418693dc5a1d791a0045a49fb128d715f91ec5bcca6d4bb6812e19b7a5438bcb27d239f2aba7de8b859d4e8e73027c59665f SHA512 801f59cdce48f7be3045c44d207a5a269bc1cd5ca9f0536d3d16f10ce82794a7e5cd5d3c83982927cebc52e1b1dbd47532140bcedca0ca4ace45b726aa0343ee
diff --git a/dev-python/typed-ast/typed-ast-1.2.0.ebuild b/dev-python/typed-ast/typed-ast-1.2.0.ebuild
new file mode 100644
index 000000000000..30650780d21c
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.2.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"