summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-22 10:47:00 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-22 10:47:00 +0100
commitbcf1494c50e606bb0ac0a7b49afeaa9c2b2c2d52 (patch)
tree0f38a5433e3baab3117faf72b83c48fee9faeeb0
parentsys-devel/binutils-config: tweak metadata.xml description (diff)
downloadgentoo-bcf1494c50e606bb0ac0a7b49afeaa9c2b2c2d52.tar.gz
gentoo-bcf1494c50e606bb0ac0a7b49afeaa9c2b2c2d52.tar.bz2
gentoo-bcf1494c50e606bb0ac0a7b49afeaa9c2b2c2d52.zip
sys-devel/gcc-config: add USE=+native-symlinks flag
This flag guards presence of 'cc', 'gcc' and friends. Bug: https://bugs.gentoo.org/724454 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-devel/gcc-config/gcc-config-9999.ebuild5
-rw-r--r--sys-devel/gcc-config/metadata.xml11
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-devel/gcc-config/gcc-config-9999.ebuild b/sys-devel/gcc-config/gcc-config-9999.ebuild
index c27a2a1f2a82..b599996f2b31 100644
--- a/sys-devel/gcc-config/gcc-config-9999.ebuild
+++ b/sys-devel/gcc-config/gcc-config-9999.ebuild
@@ -18,14 +18,15 @@ DESCRIPTION="Utility to manage compilers"
HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+IUSE="+native-symlinks"
RDEPEND=">=sys-apps/gentoo-functions-0.10"
src_compile() {
emake CC="$(tc-getCC)" \
PV="${PV}" \
- SUBLIBDIR="$(get_libdir)"
+ SUBLIBDIR="$(get_libdir)" \
+ USE_NATIVE_LINKS="$(usex native-symlinks)"
}
src_install() {
diff --git a/sys-devel/gcc-config/metadata.xml b/sys-devel/gcc-config/metadata.xml
index e396f3755977..33e9604b0414 100644
--- a/sys-devel/gcc-config/metadata.xml
+++ b/sys-devel/gcc-config/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>toolchain@gentoo.org</email>
- <name>Gentoo Toolchain Project</name>
-</maintainer>
+ <maintainer type="project">
+ <email>toolchain@gentoo.org</email>
+ <name>Gentoo Toolchain Project</name>
+ </maintainer>
+ <use>
+ <flag name="native-symlinks">Install native symlinks like 'gcc' or 'g++' to /usr/bin. Otherwise keep only ${CTARGET}-gcc and friends.</flag>
+ </use>
</pkgmetadata>