summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-04 21:25:40 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-04 21:32:25 +0200
commitbcfb8cbaf2ba393d0959684675c3913e44338dc3 (patch)
treefa777e228a7a0cb05d055838deeac56ff04a74c2
parentapp-emulation/crossover-bin: Bump to 21.0.0 (diff)
downloadgentoo-bcfb8cbaf2ba393d0959684675c3913e44338dc3.tar.gz
gentoo-bcfb8cbaf2ba393d0959684675c3913e44338dc3.tar.bz2
gentoo-bcfb8cbaf2ba393d0959684675c3913e44338dc3.zip
sci-libs/ceres-solver: Bump to 2.0.0
* Based off of sci-libs/ceres-solver-1.14.0. * Uses existing `USE=openmp` to set new CERES_THREADING_MODEL cmake variable. * Fixes error where `Eigen3Config.cmake` is missing. * Add `USE=system-mathjax` and associated patch to enable generated doc to use local MathJax to render embedded math. Closes: https://bugs.gentoo.org/806409 Signed-off-by: Brian R McCarter <brian.r.mccarter.ctr@us.navy.mil> Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/ceres-solver/Manifest1
-rw-r--r--sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild104
-rw-r--r--sci-libs/ceres-solver/files/ceres-solver-2.0.0-system-mathjax.patch10
3 files changed, 115 insertions, 0 deletions
diff --git a/sci-libs/ceres-solver/Manifest b/sci-libs/ceres-solver/Manifest
index 941bf4bbf4f1..3a08363f7eda 100644
--- a/sci-libs/ceres-solver/Manifest
+++ b/sci-libs/ceres-solver/Manifest
@@ -1 +1,2 @@
DIST ceres-solver-1.14.0.tar.gz 5450130 BLAKE2B cfcfe07cecb267528081dfc6deb5283bc5a04b79d4595e45365960895b84a6dca2a3024b046868f06709fc81e8514730cbc409ab01cb0cbee488b5bad5b9f7cc SHA512 a2af9918d2730709361ec971431a2b22e6ca3ca440081be87fa52729ec43702020b021837bfe5a42a58db1ab89ea6aada11f2d1888da66bef614ec1f27ab30c6
+DIST ceres-solver-2.0.0.tar.gz 11225245 BLAKE2B 1761908747d460f6a84cb519b4bbb49fec7e1e36cc616b438c45ace57d10bd3bb4d0cb2795e07d5096e0b9453511c185ffdd3872e317aa8095daeb86933643b0 SHA512 843b19389f4d628b2b8b8538655cb330e092ffcc960c6896c6e3065b3a34e330c81e993b7abcd754e575742e2104087efde3526945c92f7df3f6b700984e49f9
diff --git a/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild b/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild
new file mode 100644
index 000000000000..771ac309e41c
--- /dev/null
+++ b/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{8..10} )
+DOCS_BUILDER="sphinx"
+DOCS_DEPEND="dev-python/sphinx_rtd_theme"
+DOCS_DIR="docs/source"
+inherit cmake-multilib python-any-r1 docs toolchain-funcs
+
+DESCRIPTION="Nonlinear least-squares minimizer"
+HOMEPAGE="http://ceres-solver.org/"
+SRC_URI="http://ceres-solver.org/${P}.tar.gz"
+
+LICENSE="sparse? ( BSD ) !sparse? ( LGPL-2.1 ) cxsparse? ( BSD )"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxsparse examples gflags lapack openmp +schur sparse test"
+
+REQUIRED_USE="test? ( gflags ) sparse? ( lapack ) abi_x86_32? ( !sparse !lapack )"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="${PYTHON_DEPS}
+ >=dev-cpp/eigen-3.3.4:3
+ lapack? ( virtual/pkgconfig )
+ doc? ( dev-libs/mathjax )
+"
+RDEPEND="
+ dev-cpp/glog[gflags?,${MULTILIB_USEDEP}]
+ cxsparse? ( sci-libs/cxsparse )
+ lapack? ( virtual/lapack )
+ sparse? (
+ sci-libs/amd
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod[metis(+)]
+ sci-libs/colamd
+ sci-libs/spqr
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md VERSION )
+
+PATCHES=( "${FILESDIR}/${P}-system-mathjax.patch" )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ if [[ $(tc-getCXX) == *g++* ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ fi
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # search paths work for prefix
+ sed -e "s:/usr:${EPREFIX}/usr:g" \
+ -i cmake/*.cmake || die
+
+ # remove Werror
+ sed -e 's/-Werror=(all|extra)//g' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ # CUSTOM_BLAS=OFF EIGENSPARSE=OFF MINIGLOG=OFF CXX11=OFF
+ local mycmakeargs=(
+ -DBUILD_BENCHMARKS=OFF
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DGFLAGS=$(usex gflags)
+ -DLAPACK=$(usex lapack)
+ -DSCHUR_SPECIALIZATIONS=$(usex schur)
+ -DCXSPARSE=$(usex cxsparse)
+ -DSUITESPARSE=$(usex sparse)
+ -DEigen3_DIR=/usr/$(get_libdir)/cmake/eigen3
+ -DCERES_THREADING_MODEL=$(usex openmp OPENMP CXX_THREADS)
+ )
+ use doc && mycmakeargs+=(
+ -DCERES_DOCS_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ use sparse || use cxsparse || mycmakeargs+=( -DEIGENSPARSE=ON )
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples data
+ fi
+}
diff --git a/sci-libs/ceres-solver/files/ceres-solver-2.0.0-system-mathjax.patch b/sci-libs/ceres-solver/files/ceres-solver-2.0.0-system-mathjax.patch
new file mode 100644
index 000000000000..61e0f000f267
--- /dev/null
+++ b/sci-libs/ceres-solver/files/ceres-solver-2.0.0-system-mathjax.patch
@@ -0,0 +1,10 @@
+diff -urN a/docs/source/conf.py b/docs/source/conf.py
+--- a/docs/source/conf.py 2020-10-25 22:25:47.000000000 -0500
++++ b/docs/source/conf.py 2021-07-29 09:44:35.488893188 -0500
+@@ -252,3 +252,6 @@
+ 'scale' : 90
+ }
+ }
++
++# Use system MathJax
++mathjax_path = "/usr/share/mathjax/MathJax.js?config=TeX-MML-AM_CHTML"