summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-10 15:26:06 +0100
committerSam James <sam@gentoo.org>2022-03-15 17:31:23 +0000
commitbd003ff3ac0a077118ab9e33783fd9e2408a4274 (patch)
treeeabcb99471cd5e0e3492c83d7d518ebf45f2a1d1
parentdev-db/pspg: Bump to 5.5.4 (diff)
downloadgentoo-bd003ff3ac0a077118ab9e33783fd9e2408a4274.tar.gz
gentoo-bd003ff3ac0a077118ab9e33783fd9e2408a4274.tar.bz2
gentoo-bd003ff3ac0a077118ab9e33783fd9e2408a4274.zip
app-misc/fdutils: Fix direct calls to "ar"
Closes: https://bugs.gentoo.org/834874 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Closes: https://github.com/gentoo/gentoo/pull/24477 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/fdutils/fdutils-5.6_p2.ebuild2
-rw-r--r--app-misc/fdutils/files/fdutils-5.6_p2-variable-ar.patch30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/fdutils/fdutils-5.6_p2.ebuild b/app-misc/fdutils/fdutils-5.6_p2.ebuild
index b49bc20f491a..715dea769e48 100644
--- a/app-misc/fdutils/fdutils-5.6_p2.ebuild
+++ b/app-misc/fdutils/fdutils-5.6_p2.ebuild
@@ -39,11 +39,13 @@ src_prepare() {
"${FILESDIR}"/fdutils-5.5.20060227-r1-parallel.patch # bug 315577
"${FILESDIR}"/fdutils-5.6_p2-parallel.patch
"${FILESDIR}"/fdutils-5.6_p2-docs-build.patch
+ "${FILESDIR}"/fdutils-5.6_p2-variable-ar.patch
)
default
eautoreconf
+ touch ar-lib || die # bug 834874
}
src_configure() {
diff --git a/app-misc/fdutils/files/fdutils-5.6_p2-variable-ar.patch b/app-misc/fdutils/files/fdutils-5.6_p2-variable-ar.patch
new file mode 100644
index 000000000000..14a01ba20677
--- /dev/null
+++ b/app-misc/fdutils/files/fdutils-5.6_p2-variable-ar.patch
@@ -0,0 +1,30 @@
+Add variable for ${AR}
+--- a/configure.in
++++ b/configure.in
+@@ -6,6 +6,7 @@ AC_PROG_MAKE_SET
+
+ dnl Checks for compiler
+ AC_PROG_CC
++AM_PROG_AR
+ AC_PROG_GCC_TRADITIONAL
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -21,6 +21,7 @@ sysconfdir = $(DESTDIR)@sysconfdir@
+ datarootdir = $(DESTDIR)@datarootdir@
+
+ CC = @CC@
++AR = @AR@
+ PID = -DPIDFILE=\"@localstatedir@/run/diskseekd.pid\"
+ DEFINES = $(DEFINES) $(PID) -DSYSCONFDIR=\"@sysconfdir@\"
+ DEFS = @DEFS@ -DSYSCONFDIR=\"@sysconfdir@\"
+@@ -69,7 +70,7 @@ lex.%.c: %.lex
+ lex -P$* $<
+
+ libfdutils.a: $(LIBFILES)
+- ar rcs $@ $^
++ $(AR) rcs $@ $^
+
+ floppycontrol.o getfdprm setfdprm: /usr/include/linux/fd.h
+ diskseekd.o superformat.o fdrawcmd.o: /usr/include/linux/fd.h \