summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-07 18:44:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-08 21:17:22 +0100
commitbd2cf6d0b58c6ea48f59fb7640898ccd9e2aa7f6 (patch)
treebd0e3927a6d7e03cc16128e5cb2ec77cbf634728
parentdev-util/rustup: migrate to GIT_CRATES in cargo.eclass (diff)
downloadgentoo-bd2cf6d0b58c6ea48f59fb7640898ccd9e2aa7f6.tar.gz
gentoo-bd2cf6d0b58c6ea48f59fb7640898ccd9e2aa7f6.tar.bz2
gentoo-bd2cf6d0b58c6ea48f59fb7640898ccd9e2aa7f6.zip
dev-db/mysql-connector-c++: drop 1.1.12-r2
Bug: https://bugs.gentoo.org/834439 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-db/mysql-connector-c++/Manifest1
-rw-r--r--dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.11-fix-mariadb.patch43
-rw-r--r--dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.6-fix-cmake.patch23
-rw-r--r--dev-db/mysql-connector-c++/metadata.xml1
-rw-r--r--dev-db/mysql-connector-c++/mysql-connector-c++-1.1.12-r2.ebuild54
5 files changed, 0 insertions, 122 deletions
diff --git a/dev-db/mysql-connector-c++/Manifest b/dev-db/mysql-connector-c++/Manifest
index 1c28ab870e80..c823918eba96 100644
--- a/dev-db/mysql-connector-c++/Manifest
+++ b/dev-db/mysql-connector-c++/Manifest
@@ -1,4 +1,3 @@
-DIST mysql-connector-c++-1.1.12.tar.gz 518615 BLAKE2B 386a4753ca3f03999a49a89507da1b1172b3db89797c38403fee4eea86e7108a5e4f91f24a17de86d585c2a3d9e5742a117fa84d9b14aad649f938a597f3dae9 SHA512 d7e132dbc2efda4a77f8ae00c24006a1ade1d0a50f22d89ece453505e6d206427ee7988df29c0d6ef8b396ad6b8d326b6d263a1d4fa08ef5db0966fb4f1479f4
DIST mysql-connector-c++-8.0.27-src.tar.gz 4004836 BLAKE2B e581c679d8d9a31d2570b9cf1968b4e793cfccbd4cafdc5a9c9d17a465c16faa1492b2da7bdc1679d97474c27b6353274a390668f77d3cb47f72598eb3a967fa SHA512 3da7109efd2d1af813931b923218de9a85afe20d23e2654eecfa5524431f5b11ebdb8421b14563300b66ab61714e284cc15407a3b28a87922c9a8c79b2804bf3
DIST mysql-connector-c++-8.0.31-src.tar.gz 4201904 BLAKE2B 48385db732572ccf2ba91edca0fbdecf94b3ac5ca6c095e1e2e525e5f9b17749b9cb1ed9732253f9239296d364a69a91d56f60958eb4cf399f16db38f6bd76a8 SHA512 a088936e207926031b6bafe45925bf0c9d2acede9477b605adb09dc875c87965e58e3ecd0332168021122c9def831f0dfdb837ad2c4ea2f140b07b43c9f8bb3c
DIST mysql-connector-c++-8.0.32-src.tar.gz 4202413 BLAKE2B fe15be7b6ec0c4699ded6e392f3f2e1c12fa9fe033172f6219916fb6ce4ae78d3e8cc882eaf66da606dc1445a59a5cf573f92ee6f1d18178d6c11762dcffb0c0 SHA512 cdfddaf84efe0d49d07c5ef07b5c50bde2f64cbf58d48016573a20ca372b0ba5dab640305d16d8b34032a63f2ceb2954eac108f838fb2f3849a7f3838329df48
diff --git a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.11-fix-mariadb.patch b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.11-fix-mariadb.patch
deleted file mode 100644
index 2868a3c024af..000000000000
--- a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.11-fix-mariadb.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- a/driver/mysql_connection.cpp
-+++ b/driver/mysql_connection.cpp
-@@ -1067,6 +1067,7 @@ MySQL_Connection::getClientOption(const sql::SQLString & optionName, void * opti
- proxy->get_character_set_info(&cs);
- *(static_cast<int *>(optionValue)) = cs.mbmaxlen;
- /* mysql_get_option() was added in mysql 5.7.3 version */
-+#if !defined( MARIADB_BASE_VERSION ) && !defined ( MARIADB_VERSION_ID )
- } else if ( proxy->get_server_version() >= 50703 ) {
- try {
- if (GET_CONN_OPTION(optionName, optionValue, intOptions)) {
-@@ -1080,6 +1081,7 @@ MySQL_Connection::getClientOption(const sql::SQLString & optionName, void * opti
- CPP_ERR_FMT("Unsupported option : %d:(%s) %s", proxy->errNo(), proxy->sqlstate().c_str(), proxy->error().c_str());
- throw e;
- }
-+#endif
- }
- }
- /* }}} */
-@@ -1097,11 +1099,13 @@ MySQL_Connection::getClientOption(const sql::SQLString & optionName)
- MY_CHARSET_INFO cs;
- proxy->get_character_set_info(&cs);
- return cs.dir ? sql::SQLString(cs.dir) : "";
-+#if !defined( MARIADB_BASE_VERSION ) && !defined ( MARIADB_VERSION_ID )
- } else if ( proxy->get_server_version() >= 50703 ) {
- const char* optionValue= NULL;
- if (GET_CONN_OPTION(optionName, &optionValue, stringOptions)) {
- return optionValue ? sql::SQLString(optionValue) : "";
- }
-+#endif
- }
- return "";
- }
---- a/driver/nativeapi/libmysql_static_proxy.cpp
-+++ b/driver/nativeapi/libmysql_static_proxy.cpp
-@@ -325,7 +325,7 @@ LibmysqlStaticProxy::options(MYSQL * mysql, enum mysql_option option, const void
- int
- LibmysqlStaticProxy::get_option(MYSQL * mysql, enum mysql_option option, const void *arg)
- {
--#if MYSQL_VERSION_ID >= 50703
-+#if MYSQL_VERSION_ID >= 50703 && !defined( MARIADB_BASE_VERSION ) && !defined ( MARIADB_VERSION_ID )
- if (::mysql_get_option(mysql, option, arg)) {
- throw sql::InvalidArgumentException("Unsupported option provided to mysql_get_option()");
- } else {
diff --git a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.6-fix-cmake.patch b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.6-fix-cmake.patch
deleted file mode 100644
index 18d4e9a80410..000000000000
--- a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.6-fix-cmake.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -aurN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2015-06-04 08:58:30.000000000 -0400
-+++ b/CMakeLists.txt 2015-07-21 10:41:59.081091000 -0400
-@@ -300,7 +300,7 @@
- SET(CPACK_PACKAGE_FILE_NAME "${CPACK_PACKAGE_INSTALL_DIRECTORY}")
- ENDIF(WIN32)
-
--SET(DOC_DESTINATION ".")
-+SET(DOC_DESTINATION ${INSTALL_DOCS})
- IF(RPM_LAYOUT)
- SET(DOC_DESTINATION "share/doc/${CPACK_PACKAGE_NAME}-${MYSQLCPPCONN_VERSION}")
- ENDIF()
-@@ -373,10 +373,6 @@
- ADD_SUBDIRECTORY(cppconn)
- ADD_SUBDIRECTORY(driver)
- ADD_SUBDIRECTORY(examples)
--ADD_SUBDIRECTORY(test)
--ADD_SUBDIRECTORY(test/framework)
--ADD_SUBDIRECTORY(test/CJUnitTestsPort)
--ADD_SUBDIRECTORY(test/unit)
-
- IF(DEFINED CMAKE_SYSTEM_NAME AND ${CMAKE_SYSTEM_NAME} STREQUAL "SunOS")
- # see also README
diff --git a/dev-db/mysql-connector-c++/metadata.xml b/dev-db/mysql-connector-c++/metadata.xml
index 41a2871986c3..bf1ec7ca65a3 100644
--- a/dev-db/mysql-connector-c++/metadata.xml
+++ b/dev-db/mysql-connector-c++/metadata.xml
@@ -6,7 +6,6 @@
<name>MySQL</name>
</maintainer>
<use>
- <flag name="gcov">Build coverage support</flag>
<flag name="legacy">Build the legacy 1.x API as well as the DevX API</flag>
</use>
<upstream>
diff --git a/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.12-r2.ebuild b/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.12-r2.ebuild
deleted file mode 100644
index e4f89b29bcd2..000000000000
--- a/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.12-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="MySQL database connector for C++ (mimics JDBC 4.0 API)"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/cpp/"
-SRC_URI="https://dev.mysql.com/get/Downloads/Connector-C++/${P}.tar.gz"
-
-LICENSE="Artistic GPL-2"
-SLOT="0/7"
-KEYWORDS="amd64 arm ~arm64 ~ppc ppc64 sparc x86"
-IUSE="debug examples gcov"
-
-DEPEND="
- dev-db/mysql-connector-c:=
- dev-libs/boost:=
- dev-libs/openssl:0=
- !<dev-db/mysql-connector-c-6.1.8"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.6-fix-cmake.patch"
- "${FILESDIR}/${PN}-1.1.11-fix-mariadb.patch"
-)
-
-src_configure() {
- # native lib/wrapper needs this!
- append-flags -fno-strict-aliasing
-
- local mycmakeargs=(
- -DMYSQLCPPCONN_BUILD_EXAMPLES=OFF
- -DMYSQLCPPCONN_ICU_ENABLE=OFF
- -DMYSQLCPPCONN_TRACE_ENABLE=$(usex debug)
- -DMYSQLCPPCONN_GCOV_ENABLE=$(usex gcov)
- -DINSTALL_DOCS="share/doc/${PF}"
- -DMYSQL_CXX_LINKAGE=0
- -DMYSQL_INCLUDE_DIR=$(mysql_config --variable=pkgincludedir)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- rm "${ED}"/usr/$(get_libdir)/libmysqlcppconn-static.a || die
-
- # examples
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}