summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-02-23 10:06:33 +0100
committerFabian Groffen <grobian@gentoo.org>2024-02-23 10:09:16 +0100
commitbd31a1fd62028a9d13fe4966fafdc6039598580d (patch)
tree177e60186c54e7363fa7bf1472ca03237395c56a
parentkde-apps/cantor: -j1 workaround (diff)
downloadgentoo-bd31a1fd62028a9d13fe4966fafdc6039598580d.tar.gz
gentoo-bd31a1fd62028a9d13fe4966fafdc6039598580d.tar.bz2
gentoo-bd31a1fd62028a9d13fe4966fafdc6039598580d.zip
mail-mta/exim: DANE support cannot be disabled using OpenSSL
require USE=dane with OpenSSL to make the code compile Closes: https://bugs.gentoo.org/925108 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--mail-mta/exim/exim-4.97.1-r5.ebuild9
-rw-r--r--mail-mta/exim/exim-4.97.1.ebuild9
2 files changed, 12 insertions, 6 deletions
diff --git a/mail-mta/exim/exim-4.97.1-r5.ebuild b/mail-mta/exim/exim-4.97.1-r5.ebuild
index 8ac924524bb1..797f5ff6b84b 100644
--- a/mail-mta/exim/exim-4.97.1-r5.ebuild
+++ b/mail-mta/exim/exim-4.97.1-r5.ebuild
@@ -12,6 +12,7 @@ socks5 spf sqlite srs +ssl syslog tdb tcpd +tpda X"
REQUIRED_USE="
arc? ( dkim spf )
dane? ( ssl !gnutls )
+ !dane? ( ssl? ( gnutls ) )
dmarc? ( dkim spf )
dkim? ( ssl !gnutls )
gnutls? ( ssl )
@@ -19,12 +20,14 @@ REQUIRED_USE="
|| ( berkdb gdbm tdb )
"
# NOTE on USE="gnutls dane", gnutls[dane] is masked in base, unmasked
-# for x86 and amd64 only, due to this, repoman won't allow depending on
-# gnutls[dane] for all else. Because we cannot express USE=dane when
+# for x86 and amd64 only (probably due to unbound dep)
+# Exim supports it but we cannot express the dep USE=dane when
# USE=gnutls is in effect only in package.use.mask, the only option we
# have left is to a) ignore the dependency (but that results in bug
# #661164) or b) mask the usage of USE=dane with USE=gnutls. Both are
-# incorrect, but b) is the only "correct" view from repoman.
+# incorrect, but b) is the only "correct" view from dep-pointofview.
+# Bug #925108 showed that DANE is basically non-optional with OpenSSL,
+# so we make -dane mandatory to use gnutls. Bleh.
# We cannot express a required use for berkdb/gdbm/tdb correctly because
# berkdb and gdbm are both enabled in base profile
diff --git a/mail-mta/exim/exim-4.97.1.ebuild b/mail-mta/exim/exim-4.97.1.ebuild
index 4c9425c5df01..01c2c81116af 100644
--- a/mail-mta/exim/exim-4.97.1.ebuild
+++ b/mail-mta/exim/exim-4.97.1.ebuild
@@ -12,6 +12,7 @@ socks5 spf sqlite srs +ssl syslog tdb tcpd +tpda X"
REQUIRED_USE="
arc? ( dkim spf )
dane? ( ssl !gnutls )
+ !dane? ( ssl? ( gnutls ) )
dmarc? ( dkim spf )
dkim? ( ssl !gnutls )
gnutls? ( ssl )
@@ -19,12 +20,14 @@ REQUIRED_USE="
|| ( berkdb gdbm tdb )
"
# NOTE on USE="gnutls dane", gnutls[dane] is masked in base, unmasked
-# for x86 and amd64 only, due to this, repoman won't allow depending on
-# gnutls[dane] for all else. Because we cannot express USE=dane when
+# for x86 and amd64 only (probably due to unbound dep)
+# Exim supports it but we cannot express the dep USE=dane when
# USE=gnutls is in effect only in package.use.mask, the only option we
# have left is to a) ignore the dependency (but that results in bug
# #661164) or b) mask the usage of USE=dane with USE=gnutls. Both are
-# incorrect, but b) is the only "correct" view from repoman.
+# incorrect, but b) is the only "correct" view from dep-pointofview.
+# Bug #925108 showed that DANE is basically non-optional with OpenSSL,
+# so we make -dane mandatory to use gnutls. Bleh.
# We cannot express a required use for berkdb/gdbm/tdb correctly because
# berkdb and gdbm are both enabled in base profile