summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-17 07:46:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-17 08:02:17 +0200
commitbd3e6c514464c4df95d3e0734c16fa14b87a39f0 (patch)
tree9cb2e6a76d8827a799e493419e43ceaea6f8207c
parentdev-python/colorama: Bump to 0.4.5 (diff)
downloadgentoo-bd3e6c514464c4df95d3e0734c16fa14b87a39f0.tar.gz
gentoo-bd3e6c514464c4df95d3e0734c16fa14b87a39f0.tar.bz2
gentoo-bd3e6c514464c4df95d3e0734c16fa14b87a39f0.zip
dev-python/ipyparallel: Bump to 8.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.4.0.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 7daa2fd073a4..35dd53e61f24 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -4,3 +4,4 @@ DIST ipyparallel-8.1.0.tar.gz 9365732 BLAKE2B 847931de17f61b537a6350358a1fcc8e62
DIST ipyparallel-8.2.0.tar.gz 9367069 BLAKE2B e4e881f774422ead72778d40d85e5732d7da8e8e66107c06d65557c6701c94bd5c2592cea2def8b2ad405db78fe70c87944e4b89eb9fe3a4bcf38464b008979a SHA512 f6e62eaa86fa63ef1417e850de3eaf5ba228a1ad1da99c66b64b371010b57ba805201f18c97485ded24899afe7b22edbec23ca0e21344e9c2c2eacfcd6fd8adf
DIST ipyparallel-8.2.1.tar.gz 9367709 BLAKE2B 5be16c1060a31295e6b1908cfa3530d7ade6337de78ee057f595ab94ed5dc6c4c49b08f39ded0e8b6aa11ee7eda788f27b2f57bad851908f805d681e0b98efc3 SHA512 d06d1e272e27c0941f0fd6799cc78bbaf188ba1fb22f03016925ffbbf6b3e273eb8c372d7c0509b2f044ccfbfe3f35071547712e79a26a802e673340021921ac
DIST ipyparallel-8.3.0.tar.gz 6862893 BLAKE2B 9009f0fa06422b4dcd9e920d6a568030ff9b20695f3a9eab0f730b48c08465bba7682929c139bac3ef65739be2152224ca922faa6a02b6d73be2f3fb572afa26 SHA512 01ae448cd3274aa752abb033706e77584bc164c7cad626970269e516d33dda949fc0bab9a5cc3f018b2aaac60ee55078780c02ba3c9a2079f12036a869a1f339
+DIST ipyparallel-8.4.0.tar.gz 6842960 BLAKE2B e39c37759e3f6fcf12cb052aac0774435c8f7443c518b834d8d9e91a34549c8a612e603c2b541b79f8001babffc82469a4029eaa9fbda2b889fe06453b1c94d3 SHA512 ac3ef5bb733f8879dc76277bcc5be2e614000241045567ba4f23793641a523620ff8c246fd8785c81fa380c98f536cf8ef56b3bda7850b5db68d7232714b3a1b
diff --git a/dev-python/ipyparallel/ipyparallel-8.4.0.ebuild b/dev-python/ipyparallel/ipyparallel-8.4.0.ebuild
new file mode 100644
index 000000000000..1a3d355d160d
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-8.4.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="
+ https://ipyparallel.readthedocs.io/
+ https://github.com/ipython/ipyparallel/
+ https://pypi.org/project/ipyparallel/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-18[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-4.4[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/flit_core[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipython[test]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-tornado[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package myst_parser
+# distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.1.0-test-timeouts.patch
+)
+
+src_configure() {
+ export IPP_DISABLE_JS=1
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # we don't run a mongo instance for tests
+ ipyparallel/tests/test_mongodb.py::TestMongoBackend
+ # TODO
+ ipyparallel/tests/test_util.py::test_disambiguate_ip
+ # Gets upset that a timeout _doesn't_ occur, presumably because
+ # we're cranking up too many test timeouts. Oh well.
+ # bug #823458#c3
+ ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
+ # We could patch the timeout for these too but they're going to be inherently
+ # fragile anyway based on what they do.
+ ipyparallel/tests/test_client.py::TestClient::test_activate
+ ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
+ ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
+ )
+ [[ ${EPYTHON} == python3.10 ]] && EPYTEST_DESELECT+=(
+ # failing due to irrelevant warnings
+ ipyparallel/tests/test_client.py::TestClient::test_local_ip_true_doesnt_trigger_warning
+ )
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter Notebook integration" dev-python/notebook
+}